WIFI to POD not visible- cant connect to pod


#1

After initial setup. last night. This a.m. the flytpod wifi is not showing up so I cannot connect to the flytpod.
running ‘Acrylic WIFI’ doesn’t show any wifi signal. My local router is 47 dbm, and It’s registering routers i nteh neighborhood as low as -94 dbm I cannot/do not see any flytpod wifi being identified to connect to! Two different laptops under Win10 and none are showing a flytpod wifi to connect to!!! what possible name might it be identifying itself as ??

how the heck can I connect to check/fix possible configuration issues?? I have a fast blink red status led, wifi blue led is lit solid and the power led is on solid red.

I see this ‘prodiuction’ unit has a switch doen insdie from on top that I assume is a WIFI module on/off switch…reset and power up with that switch on or off makes no difference. The wifi is not showing up as an active single to connect to


No wifi AGAIN! BACK TO SQURE ONE!
#2

In which mode you have configured last, AP or Client? And whether this problem happened while you tried to switch between the AP or Client Mode?


#3

If you tried to switch to client mode (to connect to your home network) and the connection failed then flytpod will automatically switch back to previous settings. So either FlytPOD will connect to network or switch back to previous AP mode settings.
In case you don’t see either you can refer to advanced wifi setup page.
Connect FlytPOD to monitor using HDMI display, you will get the linux UI. Open a terminal and access the serial console of router as shown on the advanced setup page. Then reset the router. It will create a default hostspot.


#4

fianally got back in… had to hook up a monitor and keyboard to the pod… was able to re-config after that. Apparent faulty shutdown?..or wifi config?..or… whatever, left the router in a faulted config. No SSID was being broadcast, yet via a direct browse was able to spot a open_wrt ssid… regardless … got it reconfig’ed and can access it again as before.
Seems like a ‘fault’ at worst should have a re-write to oem default parameters, not a dump and mal-config

ptegler


#5

Yes, router does backup the last config before attempting to apply new settings and will revert back to old one if new settings fail. But there some condition must’ve occurred beyond that.
Anyway, you can always access openwrt console.


#6

well… dead in the water again here… tried firing up the Pod to do some possible coding this evening…
can’t connect again. Plugged in a HMDI cable… and not even a display! I can see the red power LED on the bottom Odroid board and the blinking blue led on that bottom board. On boot up the fan spins up and then shuts down (obvious not warm yet having just turned it on) but I can not see any display. no WIFI either! button reset the main multicolor led will breath blue than switch to a quick flash red. I’ve tried a few variations of restes (long press…short press and powering up etc, with no change in accessability :frowning:
Am I going to have to open this case up and hook a network cable up to the ehternet port on the odroid board to gain access?

also …on this ‘pro’ board, what is the forth connector on the side with the gps (2 gps, one vi and one wide? ???
ptegler


#7

ok… update… left the monitor plugged in… powered down… let it sit awhile…
plug in the power connector…and I saw all the usual odroid (Ubuntu) text scrolling by like a normal bootup on a stand alone odroid XU4… then a black screen. nothing… then a small prompt in the top right corner telling me my networks was not connected . That little box has popped up 2-3 times over the last ten minutes…but nothing else. Am i going to have to burn a whole new image to the eMMC? I haven’t really even gotten started with this device and its crapping out already. this is n’t looking promising. :stuck_out_tongue:


#8

If you are not getting the desktop (only black screen) then you can run following commands to get it back.
on black screen, press ctrl+alt+f1
login with
username: flytpod
password: flytpod
sudo rm -rf /home/flytpod/.config

Then reboot. You will get the usual desktop back. This problem must’ve been caused because of power off during boot-up.

If you still don’t see the wifi network, try to log into wifi console as I had described above from FlytPOD desktop. Then factory reset it. If you aren’t able to reach the console then let me know.


#9

ok…display came up…
after sudo command (above) a lot of stuff scrolled by but …held the power button… some more stuff scrolled by then stopped …pulled the power cord… on repower up, had to hit the ctrl-alt-f1 to get a display… same routine… some stuff scrold then stopped. momentarily hit the power button… came up with a login… after login everything just sat at the command prompt… hit the power button… a lot of STOPPED…stuff scroleld then just sat there…powered down… repeating the sequence didin’t seem to get anything running…still no wifi showing up from my other computer or wifi monitoring


#10

Hey ptegler
I’m really sorry for your trouble. We have identified a bug wherein if the flytpod loses power while booting up, some ubuntu configuration files get corrupted. A fix for this problem would be to execute the following command in your terminal . As Dhiraj instructed, when you get stuck at the black sceen, press Ctrl+alt+F1 and login with flytpod/flytpod. Then execute:

sudo sed -i 's/autologin-user=flytpod//g' /etc/lightdm/lightdm.conf
sudo rm -rf /home/flytpod/.config

After this you should get the display back by pressing Ctrl + Alt + F7 .

The wifi issue is separate from the dark screen issue. You can also execute the wifi reset commands from the terminal you get by pressing Ctrl+Alt+F1. Then get access to the openwrt shell by typing:

sudo minicom -D /dev/ttySAC2 -b 57600

Press enter twice to see the openwrt welcome message. To factory reset the router back to AP mode enter the command
firstboot && reboot

Thank you for your patience,
Zubin


#11

thanks for the command Zubin, I’ll attempt this again this evening .
Does the autologin edit just fix this possible power issue corruption?.. or does the lightdm.conf and the removal of the .config file just fix the issue this one time to get me back on track? I ask as perhaps this can be scripted for future screw ups on my part? All of this came about with me trying to get to the wifi console.

I am concerned now though… issues related to power corrupting files. If this were to happen in the field preparing for a flight…it could REALLY put a damper on client relations… (craft = off line) not being able to perform perhaps time critical tasking.

ptegler


#12

Hi Ptegler,

Removing the .config folder solves the problem till the next time the sdcard is corrupted. This issue cropped up recently when we enabled autologin. In our testing, removing the autologin parameter (sed command) resulted in this problem being solved permanently. So you will not need to script the removal of .config folder. We have accumulated many hours for field tests without the sdcards/EMMCs corrupting before this bug was introduced. Please be assured that you can expect a reliable performance from your FlytPOD once you apply this fix. We are sorry for the inconvenience you were caused by this bug. Please get back to me once you test these commands.

Zubin


#13

I had a chance to run the commands and the CTRL-ALT F1/F7 indeed worked. Even the openwrt prompts and all came up.
I was able to reconnect with both my desktop and a tablet…
Was able to bring up the console on my desktop without a problem. I turned around to the bench with the flytPOD and notice the hdmi was dark again. .a CTRL+ALT+ F1 / F7 flashed the screens once/twice but no longer displays anything. Hit the reset button and shut down. Then noticed the tablet beside the pod was not net connected either.
The HDMI display on the pod started acting up…would turn on/off 3-5 times a minute. It didn’t matter if it it was the terminal or file manger display. I noticed the boot.ini had no display modes set like on my odroid (which I’ve beee using to debug this set of problems) . I can’t get any display at all to come up. So I plugged in my second monitor… no difference. Plugged in my odroid and all is fine monitors come up without issue. And after a reboot of the pod I can no longer get in even though
Acrylic Wi-Fi says the FlytPOD_wifii is there and xmitting,blue light flickering away…I can’t get it to connect again and can’t get the hdmi to display! aaagggghh !

ptegler


#14

…not on skype… don’t use social media (most dangerous social experiment mankind has generated to date!)

Finally got connected. The hmdi port was stuck in some odd configuration… lots of executing commends blindly, hoping stuff had completed before entering the next command. 5 hrs pf playing later the display came back.

Still had not heard back as to what the extra connector on the ‘Pro’ model is between the ‘VI’ and ‘GPS2’ ports.

Can’t get the video stream to respond in the GCS, even though it works just fine on a couple different apps right on the Pod with multiple different cameras.

Attempted to play with the demoapps… none of that seems to want to run.

Although you have plenty of documentation avail on line, haldf the time you can’t tell if you’re suppose to be running stuff on the pod itself, or only from a wifi connected browser.

On a browser on a wifi connected computer (I had to add a wifi dongle to my PC) I can get the maps to come up in the GCS. but even when the POD is connceted (cleient) so it has internet access, the google maps never come through, even though the GPS location is being traced on the screen

…lots of little idiosyncrasies to work out here. :-{

ptegler


#15

Hi ptegler,

Let me try and address some of your problems. We are taking a look at the rest of the issues.

  1. The connector between ‘VI’ and ‘GPS2’ is a ethernet connector.

  2. On your flytpod, open your browser and enter the link : http://localhost:8080 see a list of video streams. Make sure that you can see the live video stream from your camera. On your PC try this link:
    http://ip-of-flytpodpro:8080 and see if the video streams are accessible from your computer. If not check if a firewall is not blocking that port by typing: sudo ufw status on your flytpod and your pc and post the output here.

  3. Regarding the google maps issues, one possibility is that because of slow internet the maps did not load. Or another possibility is that maps loaded improperly and stayed in the browser cache. You can try refreshing the cache by pressing ctrl + shift + r a few times in your browser.

Please allow us some more time to answer the rest of your queries.

Thanks for your patience,
Zubin


#16

The extra connector that you mentioned provides access to odroid’s ethernet port. To use that you will have to turn off onboard router by flipping the wifi switch.

For HDMI issue, we aren’t sure why it should happen. We or any of other customers never really faced similar issue where HDMI port does not work at all (since those problems with XU4 are already sorted out by hardkernel). Let us know if you face these issues again, we will do thorough testing with your setup.

Documentation for demo apps is under development. Thanks for pointing out the missing details. We will update them in a day or two. For now please note that any apps labeled as ‘onboard’ (e.g. python, ros scripts) are to be run on FlytPOD. And any remote apps (web, android apps) will run on remote laptop/mobile on the same wifi network. Some demo web apps are hosted on FlytPOD itself. Please refere their documentation for details on how to use them. Also if you are facing issues with any particular app then feel free to post what didn’t really work and we will help you out to get that thing up and running. Some details on exact problem would help.


#17

took awhile but got the video stream working…had to refresh drivers ( (fail statement scrolling by during boot up)
…not sure why but maps don’t work on pod in gcs, yet I can open a second browser tab and direct google maps runs just fine…swap to tab with gcs and no maps show., but the gps pointer. does. clearing cache anda reboot had no effect.

ptegler


#18

…not sure why…second monitor had same hdmi flake out issue… bought a new cheap monitor…hdmi is working…haven’t bothered to investigate further. Is there a cable avail for the ethernet port? pin out info?

So if I’m understanding everything so far… in essence, you’ve replaced the Pixhawk telemetry radio communications as such with the wifi interface. I had an extensive LUA scripting scheme set up with my Taranis radio system to monitor craft stats in flight. How might I be able to xfr these comms across wifi back to my radio and Video telemetry? I’d like to still be able to use an RD900 style radio link to my flight controller

ptegler


#19

Does the FlytPOD have GPS fix when you are trying to load the map?

FlytPOD has a serial interface on the back io panel. Connect your rfd900 to this port and you will have a mavlink stream at 57600 baud rate. Let me know if this works for you.


#20

We haven’t yet planned on using the Ethernet port. In case you want to hack into it you can use mating connector. Just remember that you can not access that port and onboard wifi router at the same time.