Web gcs problem


#1

hello i am using web-gcs in flytos but when i set up way point and press exclude but it says reject flyt_runlogs (1).log (253.2 KB)flyt_startup.log (39.4 KB)
and here are my logs please help me


#2

Hi @111,

From the runlog you have provided, I saw this error:

e[0m[ INFO] [1522927507.653233530]: Nav: Waypoint Execute command receivede[0m
e[31m[FATAL] [1522927507.653585512]: Nav: Change RC switch position to API mode or call access_request API to enable API access. Rejecting Waipoint Execute commande[0m
e[0m[ INFO] [1522927513.793855082]: Nav: Waypoint Execute command receivede[0m
e[0m[ INFO] [1522927513.794372847]: Nav: System NOT ARMED!!! Arming System upe[0m
e[0m[ INFO] [1522927513.804423759]: Nav: Arm command receivede[0m
e[0m[ INFO] [1522927513.923947612]: Nav: CAUTION!!! Vehicle armede[0m
e[33m[ WARN] [1522927513.945473979]: FCU: Flight mode change failede[0m
e[31m[ERROR] [1522927515.951896367]: Nav: Vehicle rejected Waypoint Execute commande[0m
e[33m[ WARN] [1522927551.884834793]: FCU: Low batterye[0m

Important errors reported were:

e[31m[FATAL] [1522927507.653585512]: Nav: Change RC switch position to API mode or call access_request API to enable API access. Rejecting Waipoint Execute commande[0m

and

e[31m[ERROR] [1522927515.951896367]: Nav: Vehicle rejected Waypoint Execute commande[0m
e[33m[ WARN] [1522927551.884834793]: FCU: Low batterye[0m

In the first case, RC switch was not switched towards GUIDED/OFFBOARD mode.
In the second case, autopilot rejected waypoint execute because of ‘Low battery’ warning.


#3

Sorry to bother you,but i did turn the switch to guide positation and the battery was in good condition 3s battery with 11.6 votage. maybe it’s the FCU’s problem and i had change it to radiolink pixhawk and i will try it later. thank for your reply
best wishes


#4

i currently using radiolink minipix fly controler with apm and i think it might be the fly controller’s problem


#5

Please close this thread if your problem is resolved.