Unable to find an X11 visual which matches EGL config 9 Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface


#1

I have flashed the current release of FlytOS onto my Odroid XU4.

I have run into a snag while developing my app… No matter what I try, when I attempt to start my usb video feed with rosrun, the video feed appears for a brief second, then disappears and I get this error:

Unable to find an X11 visual which matches EGL config 9
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.

Cheese and Guvcview pull up fine.

Thanks for the help


#2

Can you mention the exact rosrun command?


#3

Also,

Please post your FlytOS version and FlytImage version(or the filename of image file downloaded). Have you tried installing the latest image available on our website. What is the name and make of your camera module ?


#4

Hi,

Good to hear from you so soon.
Installed the latest version of FlytOS. It is a ps3 usb camera.

The app is precision landing and the command is:

rosrun prec_landing prec_landing

It worked perfectly until about 11 days ago, then began throwing this error…


#5

Is it possible to update your image to the latest one available in our website?


#6

Sure, I just downloaded it yesterday. Have you made any changes since then?


#7

No we haven’t made any changes.


#8

Then it probably won’t be solved by a reinstall…

What would cause the video feed to be displayed for a second and then disappear?


#9

Are you getting video streaming in FlytConsole?


#10

This is running on odroid xu4. I didn’t want to try working with Flyt Console till this was resolved.


#11

I am sorry. I don’t understand.


#12

Achal is aware of this issue. I have been waiting for his reply, but I have not heard anything back from him.

I need to move forward with the project.


#13

@achal please shed some light. In the meantime, @HawkEye, please tell me what happens when you try to see video streaming in FlytConsole.


#14

I’ve never tried to stream video through flytconsole. We’ve never got that far before.


#15

Oh don’t worry. Its not rocket science :D. Just open up FlytConsole at http://<ip of odroid>/flytconsole.
Once it opens up, click on video widget, and then in the new window, select any topic from drop down(Select Video).


#16

Also, can you launch flytOS, and post the complete output that you get in your terminal over here. You may need to stop it once, if it is already running.


#17

Done. Nothing happens…


#18

Sorry you have to say a lot more, for me to help you out here.


#19

Video selection made, clicked on the arrow icon, nothing happens. Sitting on the select video screen.

I surfed into the odroid from my laptop, is that correct?


#20

Oh I understand now. Can you please try this as well.