Trouble getting flytconsole up


#1

I’ve got flytos set up on ubuntu mate
But I can’t get the flytconsole up from localhost or my pi’s ip address or the 10. something network.
I assume that reason is for the linux image

Could you let me know how to connect to the flytconsole in this case? Or does the previous methods listed hold but I’ve missed something?

I’ve read through related flytconsole problems in the forum, and I’m not sure how much has changed with the listed problems and solutions that I try out some things to rectify my problem, so I thought I’d get details first. I think that it hints at getting the hardware connected with my pi to get the wifi ap for flytconsole, but the rpi setting up link in the tutorial also said we can use the ip for the device to get flytconsole, so I’m not sure

My team mate has the hardware and I’m responsible for getting the software setup, so regardless of whether the flytconsole connects to the device, I’d need it to atleast show up
I’ve thought of trying to getting a public ip with the flytconsole so that my team mate can access it (create a server basically) and calibrate it and set the registration id. But for that I’d need to know what services and what files are involved in setting up this flytconsole

Could someone help me in this regard?
Thanks in advance
Ps. This question has been moved from a reply of mine in the ‘corrupt download’ topic, since I thought it was inappropriate in that topic


#2

Hi,

To begin with,
I would request you to just connect hdmi monitor to your device (RPi) and try to open up flytconsole from its own browser.

Also, try to open this logviwer web app and send me the startup and runlog.

Ofcourse, you do not need to use hdmi monitor all the time, but for the time being to debug the issue, you have to do this.

Moreover, which network is your RPi connected to?


#3

Hi
I can’t open flytconsole or logs even with my HDMI since it can’t locate the page at my ip (private ip from my hotspot)
I thought I could try getting it up from my network since I don’t have the hardware for the APM with me, it’s with my team mate
So I’m not connected to the WiFi ap mentioned in the tutorial

Is there any way to connect to flytconsole?


#4

Hi,

I cannot understand your issue.

You do not need to connect rpi to APM for the following test.
Request you to answer these Qs with yes/no.
Do you have rpi hardware’s access?
Can you connect it to hdmi monitor?
Can you open a terminal window? Run this command in the terminal: flytos_version.sh please send a screenshot of the output.
Can you open a browser on rpi? On that browser, type this in url: http://localhost/logs, send a screenshot of the same?
Can you find what network is the rpi connected to? Can you find its IP?


#5

Yes, I have an raspberry pi3 with ubuntu mate with flyt os set up
Yes, I’ve a waveshare display connected to it’s hdmi port
Yes, 1.5-4b
Yes I’ve been using midori for a browser, but it can’t open that address
The page can’t be found, the connection’s refused
Mine’s at 192.168.1.108, do you want the public ip too? It’s connected to my router(4g hotspot in particular)


#6

Hi,

I would request you to manually launch flytos. If it says that it is already running, please stop it and then launch again.
Commands for them could be found here: http://docs.flytbase.com/docs/FlytOS/Developers/Introduction.html?highlight=stop#start-stop-flytos


#7

I could run the command launch_flytOS,
but it can’t find the launch_flytOS script and the scripts folder doesn’t exist

Also when I run it, it can’t find rospack’s core api
I’ve reinstalled it twice now and checked for broken links. Do I have to reinstall it again? Is it indicative of missing files or broken code?
What are the dependencies that are missing?
Or is there code(s) I can use to check it for myself and list them or correct them?


#8

Hi,

I am sorry but I cannot help you if you do not send any screen-shots of the errors you observe.

How did you install FlytOS? Post the link that you followed to install it.


#9

The link I used to get the os for flytos:
https://ubuntu-mate.org/raspberry-pi/ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img.xz
The command to download flytos:
sudo sh -c 'curl -sSL https://downloads.flytbase.com/flytos/install/flytOS.sh | bash’
I’ve run the above command twice
sudo dpkg --configure -a
sudo apt-get upgrade --fix-broken
sudo apt-get update
Those were the commands I’ve run after it says my page can’t be opened and connection is refused

launch_flytOS
That’s the command I’ve run to restart flytos. But it failed with the message
rospack core_api not found
/scripts/launch_flytOS.sh not found
That’s the only 2 errors I’ve received from the console so far

There was no /scripts folder in my root
Please let me know if you still need the screenshots


#10

Hi,

Can you open up your $HOME/.bashrc file,
In that file, remove this line: source /opt/ros/kinetic/setup.bash (if it exists),
Open a new terminal and run launch_flytOS command again,
If it still throws the same error,
attach this file: /etc/bash.bashrc and $HOME/.bashrc


#11

I’ve changed the /etc/bash.bashrc and commented the line
I saw that ~/.bashrc had the lines
export CPATH=$CPATH:/opt/ros/kinetic/include
source /opt/ros/kinetic/setup.bash
export PYTHONPATH=$PYTHONPATH:/flyt/flytapps:/flyt/userapps
source /flyt/flytos/flytcore/setup.bash
and I saw the github page that told not to keep it there

So I removed them too and added a line to ~/.bashrc
source /etc/bash.bashrc

And I’ve rebooted the system
But rospack can’t find core_api
I thought that I could manually add the path of core_api, so instead of
$(rospack find core_api)/scripts/launch_flytOS.sh
I typed
/flyt/flytos/flytcore/share/core_api/scripts/launch_flytOS.sh

and run bash
this time, launch_flytOS kinda ran
It gave a bunch of errors
rospack Error: package ‘core_api’ not found (9 times)
bash: /scripts/check_md5_paramfile.sh: No such file or directory
cp: cannot stat ‘/launch/core_api_autopilot.launch-bak’: No such file or directory
stat: cannot stat ‘/launch/core_api_autopilot.launch’: No such file or directory

I personally think the files aren’t getting recognized since rospack can’t find core_api, since originally the bash.bashrc had the command rospack find coreapi output concateated with the launch_flytOS.sh

How do you fix the core_api link, so that rospack can find it?


#12

Hi,

I would simply request you to attach the files /etc/bash.bashrc and ./bashrc files.


#13

.bashrc (3.7 KB)
bash.bashrc (2.5 KB)

Is there something wrong with them?


#14

Hi,
remove this line for .bashrc -> source /etc/bash.bashrc

replace these lines from /etc/bash.bashrc

#source /opt/ros/kinetic/setup.bash
export PYTHONPATH=$PYTHONPATH:/flyt/flytapps:/flyt/userapps
source /flyt/flytos/flytcore/setup.bash
export CPATH=$CPATH:/opt/ros/kinetic/include

alias launch_flytOS=‘sudo /flyt/flytos/flytcore/share/core_api/scripts/launch_flytOS.sh’

alias stop_flytOS=‘sudo $(rospack find core_api)/scripts/stop_flytOS.sh’

with

source /opt/ros/kinetic/setup.bash
export PYTHONPATH=$PYTHONPATH:/flyt/flytapps:/flyt/userapps
source /flyt/flytos/flytcore/setup.bash
export CPATH=$CPATH:/opt/ros/kinetic/include

alias launch_flytOS="sudo $(rospack find core_api)/scripts/launch_flytOS.sh"
alias stop_flytOS=“sudo $(rospack find core_api)/scripts/stop_flytOS.sh”


#15

I’ve tried that. It’s no good. Same error


#16

Hi,

Did you reboot your machine or sourced /etc/bash.bashrc after making those changes?
Please attach both of your files again.
Also out put of this command:

roscore


#17

it’s not installed, nor is ros-lib and catkin isn’t installed either

when I run rosversion ros, it gives output:
Cannot locate [ros]
I’ve run source /opt/ros/kinetic/setup.bash
and tried roscore again, but it still considers it not installed

I think the problem lies in the ros environment. It’s not getting set up

Is there a link to install them all in one go?


#18

Hi,

Follow this guide to install ros, and test it out.


#19

roscore works(but it doesn’t terminate. Should that be an issue?)
rospack still can’t find the core_api
rosversion ros gives output:
unversioned


#20

Run this command instead

rosversion -d

Moreover, please share your .bashrc and /etc/bash.bashrc files.