The necessity of internet access


#1

Dear developers,

I’m aware that in order for maps to load in FlytOS that internet access is required. However, once a mission is created and loaded to the drone, does the drone still need to be able to connect to the internet to execute the given mission?

I’m wondering how well FlytOS could work in areas where there is no or limited access to internet.

Thank you in advance!


#2

FlytOS does not need Internet access for executing waypoint mission or global setpoints. Internet is required only when you are using FlytConsole (since its a web app, which can not cache map data due to google policies).
However if you are using android app or qgroundcontrol then you can cache the map when connected to internet and then use them later for planning mission even if there is no internet.


#3

Could you please elaborate on how to use QGCS/Mission Planner with FlytOS. I tried to follow the guide posted in FlytDocs however I wasn’t able to get the UDP bridge working.


#4

Can you revert back with your FlytOS version. You can get that by typing:
dpkg -s flytcore


#5

Thanks for your reply zubin!

My FlytOS version is 0.6-4d and I’m using Nvidia TX1 as the companion computer. I’m trying to launch the UDP bridge with the following command ():

$ sudo $(rospack find core_api)/scripts/start_flytOS_withUDP.sh udp://0.0.0.0:14555@192.168.1.11:14550 --checkudp

The following is the error I’m getting:

process[flytpod/mavros-1]: started with pid [3915]
[ INFO] [1485309977.551230320]: FCU URL: /dev/ttySAC0:921600
[ INFO] [1485309977.553664844]: serial0: device: /dev/ttySAC0 @ 921600 bps
[FATAL] [1485309977.570247605]: FCU: DeviceError:serial:open: No such file or directory
[flytpod/mavros-1] process has finished cleanly

Thank you in advance for any help!


#6

Hi FsuSar,
Sorry for the trouble. The documentation you are following is a bit outdated. We are still in the process of updating our documentation.
Here is the fix. Rather than using the launch command you are using, first edit the file:

/flyt/flytos/flytcore/share/core_api/launch/core_api_autopilot.launch

by changing the line
<arg name="gcs_url" value="" />
to
<arg name="gcs_url" value="udp-b://:14555@:14550" />
and then execute this command:

sudo $(rospack find core_api)/scripts/start_flytOS.sh

Please post the log generated in your terminal here, so that I can help you in troubleshooting any other issues.


#7

Zubin,

That addition seemed to solve the issue, I can now run mission planner alongside of FlytOS! Thank you!

The battery status widget still isn’t working, and there are no video topics available in the drop down menu in FlytVision. I’m attaching a link to the console output when i start FlytOS with the following command:

sudo $(rospack find core_api)/scripts/start_flytOS.sh

https://drive.google.com/open?id=0B31JDICvA_iXbFRaQWd0ZDFBVlE

Thank you once again for all your help!


#8

Hi @FsuSar
its great to hear that you got the mission planner working. Regarding your flytvision issue,assuming you are using the TX1 with its development board, the video device /dev/video0 corresponds to the onboard camera. This camera cannot be used in FlytOS so you will have to connect a usb camera/webcam on the TX1. Once you connect your camera, you enter the command
ls /dev/video*
to see what device name is assigned to the camera. Usually it will be /dev/video1.
Then edit the following launch file:
/flyt/flytos/flytcore/share/vision_apps/launch/cam_api.launch
and change the video device accordingly. If your usb cam gives an output in the mjpeg
pixel format(usually GoPro and SJCAM branded cameras), then change the pixel_format parameter from yuyv to mjpeg.

Regarding the battery widget problem, this is a bug in your FlytOS version which has been resolved now. You might want to wait a few days for the new release of FlytOS for TX1 which has many new bug fixes and feature enhancements.


Unable to read battery status