Rp3 image does not support Rpi 3 model B+, I think


#1

Hi, I’m Kevin who SW engineer.

After flashing Rpi 3 image on SD card, I’ve inserted into Rpi 3 model B+ but it can not start booting.
With Rpi 3, it works fine.

Anybody can help me?


#2

Yes, you are correct. We will release a new image for 3B+ in a few days.
In the meantime, please follow this link for setting up FlytOS in 3B+.


#3

Hi! I had the same answer the last day, but I tried to install it with the second method, installing FLYTos dependencies and works perfect. But I have another question because I´m using an APM 2.6 controller and in MissionPlanner works fine, but following the tutorial, I have to connect the APM via USB to QGroundControl and change some settings, but I connect the APM and nothing happens. I´m searching everywhere but I don´t find the way to get a connection.
If anyone know how to do it I`ll be very glad.

Thank you.


#4

Were you able to get around this issue?
Did you try using UART instead of USB to connect to QGC.


#5

I connected over UART but nothing, but then I saw that I must to cut a jumper and put a new one under the ARDUPILOT 2.6 board. Is what I have to do?? I haven’t tried yet.


#6

There seems to be an issue with RPI 3B+ UART. Please use a USB-UART module to connect APM’s UART and RPi’s USB for now. Otherwise, temporarily you can also connect APM’s USB to RPi’s USB to establish communication.


#7

Run these commands in RPI terminal:

  • sudo apt update && apt upgrade
  • sudo systemctl disable hciuart
  • sudo rpi-update

Reboot RPi, and not the UART port should be working.