ROS multimaster queries


#1

@Dhirajd @zubin @srv

We tried following the ros mulitmaster pdf that @Dhirajd recommended. We binded the host names and ip addresses, we are able to ping and ssh from one computer to the other computer through a common network (Our school wifi).

However, after keying the following codes:

  1. rosrun master_discovery_fkie master_discovery _mcast_group:=224.0.0.1
  2. rosrun master_sync_fkie master_sync

This error came out in the master_discovery tab:
[WARN] [WallTime: 1483998174.367555] MasterMonitor[/master_sync]: can’t get PID: [Errno 111] Connection refused
[WARN] [WallTime: 1483998174.686717] ERROR Service call ‘get_sync_info’ failed: unable to connect to service: [Errno 111] Connection refused
[INFO] [WallTime: 1483998174.694863] Detected master discovery: http://172.22.89.1:11611
[INFO] [WallTime: 1483998174.824921] Added master with ROS_MASTER_URI=http://flytpod:11311/
[WARN] [WallTime: 1483998176.902919] ERROR Service call ‘get_sync_info’ failed: unable to connect to service: [Errno 111] Connection refused


#2

Hi @Dhirajd,

Please respond to this query.


#3

This could be an issue with the firewall. try allowing outside connections on ros specific ports (you can find them when you run roscore) in the firewall.
For laptop you can use,

sudo ufw disable

which disables the firewall.
On odroid there is no firewall, so you should not face any firewall issue there.
Meanwhile I will replicate the scene here on my system and let you know what might have gone wrong.


#4

I tested the same flow. Did you see 224.0.0.1 in the response to this command?

netstat -g

Because in my case it showed 224.0.0.251 and I had to use the same in subsequent commands. Its working for me. Please make sure that when you ping 224.0.0.XXX ip all the devices (with multicast enabled) should respond to it. Then only there is any use of going ahead.