Pixhawk2 Intel Edison Activation issue


#1

Hi there, I have setup FlytOS on an edison installed into the Pixhawk2. All appears to be ok except i am unable to activate the account.
I have checked and the device has registered under my account.
I go to flyyconsol from a PC with internet access. enter the key. However I get a Activation Failed, check the entered key, retry.

I have tried this over and over again. in fact I got a new key, but still no activation.

any help please?

Regards
Anthony


#2

Hi, @ACPuk sorry for the inconvenience, it is unusual, we are looking into the issue right away. Can you please share with us your account name and email id so that we can check. Also could you let us know which version of flytOS you are using? You can check your flytOS version by running flytos_version.sh in your terminal.

Thanks,
Prabodh.


#3

Can you run the following commands, in edison’s terminal:

ifconfig

ethtool -P $(ls /sys/class/net/ | grep -E 'enp|eth|wlp|wlan') | grep -Po 'Permanent address: \K.*$' | sed s/://g

#4

I have sent a reply to srv’s welcome message with my login details. I can’t see how to send PMs through the forum.

You should see two devices Odroid K3-odXU4-0001 ID:- cnLXEDS7

The issue is with:-
PX2Ed-0001 Vehicle ID:- MUX075QG
You will see I have has 3x attempts to issue a key.

Regards
Anthony


#5

Hi,

Please install the latest FlytOS from https://my.flytbase.com/downloads/flytos/.
Download debian for Intel Edison.
Install it using the following command:

sudo dpkg -i flytos*.deb

Once installation is done, try to activate again. If it fails, run these commands in your terminal,

ifconfig

ethtool -P $(ls /sys/class/net/ | grep -E ‘enp|eth|wlp|wlan’) | grep -Po ‘Permanent address: \K.*$’ | sed s/://g


#6

ifconfig:-
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:134488 errors:0 dropped:0 overruns:0 frame:0
TX packets:134488 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:33421054 (31.8 MiB) TX bytes:33421054 (31.8 MiB)

usb0 Link encap:Ethernet HWaddr 02:00:86:38:40:a2
inet addr:192.168.2.15 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr fc:db:b3:9b:3a:b9
inet addr:192.168.42.1 Bcast:192.168.42.255 Mask:255.255.255.0
inet6 addr: fe80::fedb:b3ff:fe9b:3ab9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:6788 (6.6 KiB)

lp|wlan’) | grep -Po ‘Permanent address: \K.*$’ | sed s/://g| grep -E 'enp|eth|w :thumbsdown:-
000000000000


#7

Hi,

Once you update your FlytOS. Try activating it again.

EDIT: Can you please run this command as well:

ethtool -P wlan0


#8

Since the system has been running within flytconsole Update Download progress:has sat @ 76.93%
Is there a manual way to force a update?

ethtool -P wlan0:-
Permanent address: 00:00:00:00:00:00


#9

Yes, Pixhawk2 Intel Edison Activation issue exactly tells you how to manually update your FlytOS.


#10

My Apologies, I missed the previous post.
So updated to V1.34
Tried reactivating and revived Activation failed again.
Ran commands as requested. Re-activation informs me device already activated. C/P the key and again revived

“Activation Failed !!
Invalid key or device ID, Retry!
Reverting to old license if available.”

Also spotted px4 in the corner, should be Ardupilot, this may be due to non activation though.


#11

Hi,

Sorry that you are facing so many problems, getting it activated. Can you please send me the following info:

  1. Output of flytos_version.sh
  2. Stop FlytOS and then Launch it again. For commands, refer here. Once launched, kindly copy the entire logs that is printed in the terminal and paste it here.
  3. Please attach your startup log file at location /flyt/logs/startup/flyt_startup.log
  4. Also, just to be sure please install all the dependencies as mentioned over here.

#12

@ACPuk can you run following commands in terminal on Edison? please post response here.

cat /proc/cpuinfo | grep -Po ‘model name\t: \K.*$’

cat /sys/block/mmcblk0/device/cid


#13

I got the same problem as Anthony. I just wonder how Edison can have internet access, when FlytConsole is running on my PC.
Indeed, FlytConsole requires that Edison runs as access point but the key activation process can be completed only if Edison is in web-client mode. However, these two conditions cannot be fulfilled simultaneously, as mentioned here: https://communities.intel.com/thread/63307

Thanks,
Alberto


#14

Hi,

FlytConsole can work even when edison is in client mode.

Configure edison to connect to your home/office router. detailed steps are over here.

After rebooting edison, verify that it has indeed connected to your router. Also, get the edison’s IP.
Once done, connect your laptop/PC to the same home/office router to which edison is connected to.
Open browser in your laptop/PC, and go to http://<ip of edison>/flytconsole
You should see flytconsole web app loading. Once done, you have both edison connected to internet a working flytconsole.


#15

@ACPuk we had updated our edison image and improved our documentation to install it. Did you get chance to try it out?