Pixhawk not getting connected


#1

Hi guys,

I started off using FlytOS after installing Ubuntu on my Intel Aero Compute Board. After couple of connections to Pixhawk for limited time (maybe seconds), Pixhawk won’t connect anymore. I have tried to connect it alone without Intel Aero directly to QGC and Mission Planner which failed as well.

It shows errors like vehicle not responding and connection lost at the first instance itself. So far I have tried the following:

  • Formatted Pixhawk SD card and tried flashing both PX4 and Ardupilot wondering if there is a fix.
  • Tried connecting it on Ubuntu and Windows.

Is my Pixhawk device defective? Please advice.

Also, have a look at the QGC console log if you can see something is not right.

Thank you.

Robin.


#2

Hi,

What is your QGC/MissionPlanner version?
How are you connecting QGC and Pixhawk? Via usb or uart? If using uart - TELEM1 or TELEM2?
In Windows, did you try run as admin ?


#3

Hi,

Thank you for your response.
I am using QGC V 3.2.7 and running as an admin. I am connecting Pixhawk to computer. Also, I am using a USB 2.0 cable to connect Pixhawk to Intel Aero Compute Board.

Looking forward to your reply.

Robin.


#4

Can you send me a small video of you connecting Pixhawk with QGC, and it not being able to detect Pixhawk ?
Also, in QGC you would have to add connection is using UART to connect to Pixhawk.
I would also suggest you to post your issue in other QGC/Mission planner/PX4/APM forums as well.


#5

Hi Srv,

I really appreciate your time to look at the video send to you. I am not sure whether I am doing it right. Initially I wanted to connect Pixhawk using a companion computer (Intel Aero as they haven’t released their code to use aero board alone or correct me if I am wrong). But now I want to see the drone flying for to confirm that my powertrain is working and that I can now work towards learning the code and adding the companion computer for more application.

Please have a look at the video. The scenario is after flashing Pixhawk and formatting the SD card several times. Usually I flash without any connection to Pixhawk (GPS, ESC) and then try connecting Mavlink to software such as Mission planner, APM, QGC. I remember once I ran the motors alone by making it follow a waypoint on APM. That was just once and couldn’t connect afterwards.

By UART connection do you mean I have to calibrate my drone using an FTDI USB to Serial connection ? because as shown in the video, I usually connect Pixhawk using the USB btw my computer and Pixhawk.
Am I doing it wrong?

Thank you.
Best Regards

Robin.


#6

Sorry. I cannot see any video.

Did you get any help from other forums?