Pixhawk Mini/OdroidXU4 issues


#1

I’m fully able to get flytconsole running on the odroid. I’m having an issue making it ‘connect.’ I’m fairly certain the issue lies with the communication between the pixhawk and odroid.

As stated in the title I have an pixhawk mini (I wasnt able to find a good price for the original) As such I don’t have a telem port. Can I connect through the telemetry port, or directly with USB? Or am I SOL due to the pixhawk mini?


#2

Hey @KeeganVG

You can use the USB port directly. You just have to make changes to a particular file on odroid. Follow the steps in last question to know which file to edit : http://docs.flytbase.com/docs/FlytOS/Debugging/FAQ.html

When a pixhawk is connected to the Odroid , it shows up as /dev/ttyACM0 . You can confirm this on your Odroid by typing this in the terminal:

ls /dev/tty*
Then connecting the usb cable , executing the command again and seeing what has changed in the the command output. I’m pretty sure it will be /dev/ttyACM0, but no harm in checking.

Then the FCU URL will be:
<arg name="fcu_url" value="/dev/ttyACM0:921600" />

Zubin


#3

Hi,

You can always connect the telemetry port too. Just configure baud rate for that port to 921600, by setting parameter SYS_COMPANION 921600.


#4

I have same problem, but I don’t want use TELEM port for Raspberry (I use it for RFD900+)
How to connect my MINI through USB?


#5

/dev/ttyACM0 it help!!!
Thanks so much!


#6

Using ttyACM0 is fine when working in lab, but not while flying. APM does not recommend using usb while flying. If you are using PX4, then it might just be fine.