Pixhawk 2 with the Odroid XU4 (Communication)


#1

Hi there,
I have successfully installed FlytOS on my Odroid XU4 and I can see the Flytconsole when I log into the Odroid board using the IP address of the board. My next step is to connect the Pixhawk 2 with the Odroid so I can use it for telemetry over the wifi (in the future 4G). But there isn’t that much documentation about the Pixhawk 2 in combination with an Odroid XU 4 board. I am not able to set up the configuration by following the steps of docs.flytbase. because this is about the installation for the “normal” Pixhawk. If there is anybody in this group how can explain to me how to set up the Wifi telemetry (Hardware & Software) and connect it to Mission Planner/QGroundControl would be very nice!
Thank you!
Regard Dirk


#2

Well, the documentation for Pixhawk in docs.flytbase.com should work for Pixhawk2 as well. Where are you facing the problem?


#3

Thank you for your answer,
My problem is at the hardware set-up Telemetry Connection and the configuration with the Pixhawk using QGroundControl. Making a TCP Comm link gives this error: The remote host closed the connection.
Maybe it is easier to use a micro USB cable, but don’t know wich one to use. Pixhawk 2 has 3 connections…
Looking forward to your answer!
Regard


#4

Hi,

  1. Does FlytConsole say that it is ‘Connected’?
  2. Are you running APM or PX4?
  3. What is the version of your flytos?

#5

Hi,

  1. Nope, FlytConsole is not Connected to Pixhawk, receive nothing in Flytos about the Pixhawk (Stuck here). Can’t upload anything from the FlytConole but it is activated and stuff like that.
  2. As far is I know APM
  3. FlytOs v 1.21

#6

Hi,

So until we fix the first point[quote=“dirkhuijbers, post:5, topic:401”]
Nope, FlytConsole is not Connected to Pixhawk, receive nothing in Flytos about the Pixhawk
[/quote]

, [quote=“dirkhuijbers, post:3, topic:401”]
Making a TCP Comm link gives this error: The remote host closed the connection.
[/quote]

This cannot be resolved.

Now, for reference, you can check this page. It suggests to set parameters:

SERIAL2_PROTOCOL = 1 (the default) to enable MAVLink on the serial port.
SERIAL2_BAUD = 921 so the Pixhawk can communicate with the Edison at 921600 baud.
LOG_BACKEND_TYPE = 3 if you are using APSync to stream the dataflash log files to the Edison

So as mentioned here

Connect the ‘TELEM2’ port of pixhawk2 to either of two below options:

  1. to odroid’s uart port. but since odroid is 1.8V logic, you have to attach its shifter shield.
  2. to odroid’s usb port, via a usb-uart convertor.

Alternate option:
You can also connect usb port of Pixhawk to usb port of odroid.


#7

??? with or without the Edison in the base? ( i ask as you say 2-3 connections… two lower are direct Edison connections)
Software you need to disconnect the Edison if you’re hooking up an Odroid.

Odroid / pixhawk connection info is at
http://ardupilot.org/dev/docs/odroid-via-mavlink.html

ptegler


#8

Hi,
Without the Edision (thats why I try to use the Odroid, as a replacement of the edison)


#9

So @dirkhuijbers, were you able to get it working?


#10

Not yet, need some time for it.
I will contact you in a few days, thank you!


#11

@srv I’m still struggling how to set-up the communication. Did al the given steps, when I log into the flytconsole using the IP adress it says Disconnected in the header, I tried to use the micro-usb as well as the usb - uart Converter. Cant see anything about my autopilot in the Flytconsole menu.
Regard


#12

Hi,

I forgot to mention. Depending on what interface you choose, you have to make an edit to a file. Its clearly articulated here, under Need to change the baudrate/port of Flight Control Unit(Pixhawk) section.


#13

Hi,
Well finally it works, got the communication on my laptop. Few things to figure out how.

  1. When I’m in the FlytConsole true my computer (same WiFi) I see Battery; FlightMode; Disarmed; Connected. When I try to select a frame, Calibration, or anything else I receive this message: “This widget does not work with APM” what does it mean? can I solve this problem or not? <-- -solve this, upload firmware true QGC, I get in the widgets
    Now trying to calibrate everything with the FlytConsole, when I try to calibrate or set some new params recieve this message “Parameter set Failed”

  2. Can’t take off., “Failed to take off”, (Is this because I do not use FlytPOD?) I can execute the drone with a ground station and FlytOS right??

  3. Can’t figure out how to switch to offboard/API and how to install this flight mode in Mission Planner.
    (4. Next --> connect the drone through 4G.)

Sorry for al those questions, hope somebody can help me to figure out!
Thanks to you all!
Regard


#14

Hi,

  1. Decide which drone autopilot you are going to fly with. APM or PX4?
  2. When you update your autopilot firmware, make sure you choose correct autopilot.

Those FlytConsole widgets that do not work with APM will show you this message. Instead use APMPlanner or Mission Planner for APM or QgroundControl for PX4, for frame, calibration etc.

It seems you had installed PX4 while updating your firmware, which is supported by FlytConsole. That’s why you got the widgets working.

Also, how are you connected to Pixhawk? via Uart or USB? For APM, yesterday I came to know that they recommend to not use USB of Pixhawk for connecting to Companion Computer. I hope you are using UART of Pixhawk.

No, ofcourse FlytOS would work with any Companion Computer of your choice, and is not restricted to FlytPOD. Please take a look at this and post your log here.

Offboard is same as GUIDED mode. Just configure FLTMODE parameter in mission planner accordingly.


#15

I hope you have activated your device, and rebooted it once done.


#16

Thank you for your response, I will look after this and let you know.
I’m using the USB to USB, not the uart telem2 cable… have some problems witht the connection between the UART so decide to choose for USB to USB. What is the different between them?
Thanks


#17

The micro USB port (aka Serial0) is used to connect to the ground station using a USB cable. This should not be connected in flight because the flight code assumes that if it is receiving power through this port that it is on the bench and some failsafes (i.e. battery failsafe) are disabled.

apm doc link


#18

Well it is working,

Only 2 problems,

  1. When using PX4 the flytconsole is telling me: This widget is only working with APM
  • When using APM on the Pixhawk, flytcolonsole is telly me: This widget doesn’t work with APM???
  1. Now using a wifi stick to the Odorid system, I want to use a 4G dongle for long distance connection, how to do the set-up for the 4G stick because the IP-Adress will change every time.? Can anybody help me with that?

Thank you very much!


#19

Hi @dirkhuijbers,

Which widget were you talking about?

@Dhirajd can you help him with this?


#20

Hi @srv Thank you for your reaction,

I’m talking about the widgets from the flytconsole, all of them. For instance; Esc calibration, motor test, radio calibration etc…

@Dhirajd Hope you can help me, thank you!