Odroid xu4 +pixhawk


#1

Hi everyone,
I have successfully activated FlytOS. According to the tutorial ODROID-XU4, connect Pixhawk’s Telem2 port to ODROID UART0 port,and configuring Pixhawk Autopilot for running APM.On my PC’s browser using the URL http://ip-address-of-device/flytconsole to launch FlytConsole,but always disconnected and can not change the apm/px4 stack.

So how should i test the connection between odroid and pixhawk?
Thanks!


#2

Please post FlytOS’s run log and startup log. Click here to know more.


#3

flyt_runlogs.log (29.9 KB)
flyt_startup.log (103.6 KB)


#4

Hi @Bryan,

FlytOS during startup autodetects port on which autopilot is connected along with its type (APM/PX4/DJI).
Unfortunately, the run log suggests that it is not being able to detect the port.

You have connected Pixhawk’s Telem2 port(3.3V) to Odroid’s UART port (1.8V). Have you used a 3.3V-1.8V convertor? You can also use a USB-UART FTDI convertor to connect Pixhawk’s Telem2 port with Odroid’s USB port.

Moreover, have you connected the RX-TX pins correctly? RX of Odroid goes to TX of Pixhawk and vice versa.


#5

Thank you,
I have used xu4_shift_shield to convert level.I confirm that the RX-TX pins is correctly connected.Can’t detect the ports that are definitely caused by hardware connection problems?


#6

You can run this command in a new terminal:

sudo minicom -D /dev/ttyACM0

Do you see any garbled up text?
How have you configured Pixhawk? What parameters have you edited?
Can you connect Pixhawk to QGC/Mission Planner and make sure it is working fine?
Also make sure, SD Card is inserted into the Pixhawk’s card slot.


#7

When i run sudo minicom -D /dev/ttyACM0,
minicom: cannot open /dev/ttyACM0: No such file or directory
but run sudo minicom -D /dev/ttyACM99,

Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Feb 7 2016, 14:00:34.
Port /dev/ttyACM99, 06:50:33

Press CTRL-A Z for help on special keys

I have connected Pixhawk to Mission Planner,set parameters SERIAL2_BAUD and SERIAL2_PROTOCOL to 921 and 1 respectively.


#8

Have you worked with Pixhawk and APM before? Is it in ready-to-arm state?
What is its LED pattern? Can you take a small video of the LED pattern?
Have you selected the Frame Class?

I am sorry for causing the confusion, this should be the correct command:

sudo minicom -D /dev/ttySAC0

If you don’t find any garbled up data being printed, try out other ttySACx ports if you find any. If you still do not see any data, there must be some hardware fault.


#9

Thank you
I have worked with Pixhawk and APM before,The following video shows pixhawk‘s’ LED pattem and Connection between Pixhawk’s Telem2 port and ODROID UART0 port.

I run sudo minicom -D /dev/ttySAC0 and other ttySACx ,the result is:
Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Feb 7 2016, 17:23:10.
Port /dev/ttySAC*, 10:13:33

I don’t understand the -D here,When I use tab to autocomplete code, there is no -D option.
Thank you for your help!


#10

Can you make sure, odroid’s shifter shield is configured in 3.3V mode. Make sure the switch at the top of shifter shield is towards 3.3V.


#11

I’m sure the switch at the top of shifter shield is towards 3.3V.


#12

I would also request you to remove the UART connector, and instead just short the RX-TX pins of Odroid.

  • Using minicom open the ttySAC0,
  • make sure ‘hardware flow control’ is disabled in configuration settings of minicom [If you are using our Odroid image, you do not need to follow this step]
  • Then start typing anything in your keyboard.
  • If the hardware is working, you will be able to see your typed characters being printed.

-D command tells minicom to open a specific device/port (ttySAC0).


#13

According to the above steps,can see typed characters being printed.


#15

I know why no garbled characters were found before,when run sudo minicom -D /dev/ttySAC0.
Because ‘hardware flow control’ is not set to disabled.


#16

So let us start afresh.

  • Boot up Odroid
  • open a terminal and run this command:

stop_flytOS

  • next, run this command:

sudo minicom -D /dev/ttySAC0

  • verify you observe garbled up data
  • If yes, run this command in terminal:

launch_flytOS

Open FlytConsole in a browser and check ‘connection’ status. If it is still failing, send me the runlog and startup log again.


#17

After executing the command,i can observe garbled up data.

The logs indicate that the port was successfully detected, but there seem to be other issues.
flyt_runlogs (1).log (69.9 KB)
flyt_startup (1).log (702.7 KB)


#18

Everything seems fine.
The only error that I could observe was this:

No IO Thread Heartbeat

Please, checkout APM forums for this error.

Also run this command in terminal:

rostopic echo /flytos/mavros/state
rostopic echo /flytos/mavros/imu/data_euler

Please post the output of above commands in terminal.


#19

There might be an issue with dependency conflict.

Open a terminal and run this command:

sudo -H pip install tornado==4.5.1


#20

OK.Everything seems fine.

Thank you for taking the trouble to help me. I do appreciate it.


#21

So what solved your issue?