Nvidia tx2 + RoS + FlytOS


#1

I tried to connect pixhack and nvidia tx 2 board and found problems. So, I am connecting pixhack’s telemetry port to J17 UART port of nvidia tx2. Nvidia tx2 is running ros kinetic and flytos which I installed with install script from official web site. However, I cannot get any communication between pixhack and tx2. The only thing I got while streaming serial port (using ubuntu 16.04. terminal) are some weird characters which indicates to wrong baud rate. But both, pixhack and nvidia is configured to work with 921600 baud rate.
Can you give me some advice or any help regarding this problem?


#2

Hi,

Which port of Pixhack are you using to connect to TX2?
Have you earlier worked with Pixhack and any CC (with or without FlytOS) ?
How did you configure the baud rate, which parameter did you change?

What was the command that gave you this output?


#3

Telemetry port.
Yes I have. Using QGroundControl I have changed SYS_COMPANION to 921600 and MAV_COMP_ID to 50 following this guide http://docs.flytbase.com/docs/FlytOS/GettingStarted/TX1Guide.html

For streaming I used
screen /dev/ttyTHS1 921600


#4

Can you elaborate more on this please?


Also, can you confirm if you are using DBUS OP for Telemetry. I don’t have any experience using Pixhack, but I think you have to use this port. If you are already using this, are you sure that the name of serial port is indeed THS1 and not THS2? I am sure in TX1 it was THS2.


#5

Uh I connected it to RADIO since there is where telemetry was connected for radio connection. But is seems I was wrong… This could solve the problem. Thank you very much. I will keep you posted…


#6

Solved! Thank you very much! I tried everything on Ubuntu, from enabling ports to installing various serial protocols but it was this problem on the end.


#7

Hi,

Great to hear that.
Can you please attach this file: /flyt/flytos/flytcore/share/core_api/launch/core_api_autopilot.launch
Just wanted to check whether FlytOS is listening on THS1 or THS2.


#8

it uses ttyTHS2 as you said


#9

Hi! It seems I have different problem now… When I start up my drone with Nvidia Tx2 on itself, connected via UART to pixhack I see flytos console but I can not arm motors with regular RC. In fact, there is no communication at all with remote control. Is there any parameter I have to fix on pix in order to communicate with Nvidia tx2 and RC?


#10

No i am sorry, your RC should work in parallel with Tx2.