No wifi AGAIN! BACK TO SQURE ONE!


#1

UNBELIEVABLE!
after al lteh messing around with getting this pod back to the oem config a complete repeat of this thread


seems to be back!

Last night I was up and running wit hhe new IMG on the eMMC… everything was working. Ran through many of the calibration setup routines with out issue. multiple power downs and reboots all was well.

So to day after work, I’m all happy and ready to play with some of the on board apps.
I fire up the pod… COOL looky there a BREATHING GREEN LED.!! woohoo!

wait a minute… my browser won’t connect flytpod/flytconsole, multiple xxx.xxx.xxx.xxx/flytconsole attempts so I fire up Arylic wifi to see what’s bradcasting. nada zilch nothing no flyt_wifi flight_wrt is there…

so I go directly to the pod…fire up a browser…nothing i
I’m right back where I was before! The LED is breathing green even… but no connectivity
so I plugged a usb wifi module in just to see if anything was there… no change.

on the pod I installed nmap and did a scan… 192.0.0.0 and 192.168.1.200 showed up once…but not repeatable. The scan showed the rest of my home network wifi devices but nothing from the pod.
BUT THE BLUE WIFI LED IS RANDOMLY BLINKING.

I change absolutely nothing about the pod config other than client mode (and was working fine after that) and ran through a bunch of the cosnole calibrations and setup with any problems

An now today the damn thing is messed up again!!! aaaaAAAAAAHHHHHHHHHHHHH!

ptegler


No response so new topic! wifi client not staying/switching
#2

just did some digging… did my boot up this afternoon attempt to do an auto update? There were no indications, and if I hut it down mid cycle…could it have wrecked havoc on a config file somewhere?

Ther must be a config file I can copy to a dir then reboot to correct this. Or a script to pull info from a file to fix this…If a power down during an update is the issue…you need some kind of save guard here!

crap…can’t remember where but just swa (on the pod) a conf file that did indeed have autoupdate-1 in it :-


#3

ok…completely re-imaged the pod again… on the pod I can get to the console, but could only activate by plugging in a separate wifi dongle.

I can’t get the wifi to connect via the inbuilt router.

I need someway to default config the router dazed and confused here.


#4

seems like your pod has got some hardware issue. We are shipping a replacement for you tomorrow.


#5

ok…new pod here… looked like the bottom board got skewed in shipping… hdmi, usb and por ports were all barely in line wihthe case… board felt it like it snapped down a bit.

OK… I think I know what’s happening…
The screen instructions for setting up the client and the procedure in the pamphlet are not the same. do you or do you not need to reboot as the screen states… which ever it is I’m right back i nthe same boat again. Was connected…followed the screen and rebooted after two minutes after setting the client mode. after boot it would not scan and find any of the 10 or so wifi networks I see via other utilities doing a scan
started over following the pamphlet only… so a no go. Can connect to the flytpod via a laptop and get to the console, but no from my main networks. Turning off mac filtering made no difference.
The pod does not seem to want to connect via wifi to my main network. AGAIN when i’d already sen the console on my screen!
Also the ap mode says wpa1 wpa2…this new pod has some other acronym showing up… not wpa…
aaaaaHHHHHHHH! zzzzzz (1 o’clock here i nteh am I need sleep for work tomorrow)


#6

Create a wifi hotspot on your iphone. Configure it to have no password. Then connect FlytPOD to this wifi hotspot. If it works then you need to check your router’s security settings.
I have personally tested the replacement FlytPOD with multiple networks and everything works just fine. Also make sure that you have plugged in antennas.


#7

This is the type of issues/instruction where the confusion starts…
You say… “Then connect the FlytPOD to this wifi hotspot.” So in this case you’re talking keybaord and monitor plugged into the POD itself and configure the pod correct?

working from the pod (that is to say, hdmi and keybaord plugged into the FlytPOD itself) I can/could access the flytconsole, and at least at one point could open another tab in the browser and test/access google maps without issue. After re-booting,(still on the POD), using the console to setup CLIENT mode …a SCAN would not respond with a list of any wifi networks (at least 10+ are visible around my house). A manual entry (new on this pod you sent compared to the first pod) of a wifi connection config would not connect. This was tested with and without my home network router MAC filtering turned on or off. I must also note, that the oem configured FlytPOD_wifi network access, did work the first time around from my main desktop PC. It would not connect through the networks main router wifi interface after I attempted to change the CLIENT mode from the desktop PC I had to plug in a separate wifi dongle to ge to the POD via wifi.
I have an Asus router that should be showing up tonight (Amazon.com) that I plan to configure as completely free standing, specifically for field use. I will retest all this stuff again this weekend. But the confusion I believe I’m facing is the printed directions and screen prompts do not follow the same course of action when configuring the router.

Let me ask it this way… router WAN/LAN… which is the correct scenario…
1- LAN = odroid WAN is WIFI
2- WAN is odroid LAN is WIFI

In pod client mode, the pod router is accepting a DNS IP supplied (via wifi) by my home network router, and the odroid is accepting that IP address as it’s DNS (hard wired) IP address … correct?
…just trying to make sure I’m am viewing this correctly for debugging this weekend.

I just know this is all going to be some single silly little detail that is being lost in translation or sequence or missed or assumed setting not defined. :unamused:


#8

spent the better part of this evening working this wifi issue…
right now the best I can tell (looking at the openwrt interface) the wifi is OFF! turned off that is. It no longer is showing up Using the console (at the pod) to attempt to set the client mode, changes nothing. One time the SCAN for wifis to connect to, did turn up connections, but upon rebooting they were gone. manually entering a network id did not correct the lack of connect. .
I went back through the minicom and did a firstboot && reboot…it didn’t fix anything. Now the ‘openwrt’ logo isn’t even display in the minicom, nor does hitting enter twice give me a prompt.
Is there a firmware backup file anywhere on the pod for the router??
The issue I’m noticing is instruction for this simple setup on line, and in the pamphlet and on screen do not agree.
Should we be rebooting the pod and/or completely cycling power after a wifi ‘client’ setup? IE…just rebooting the odroid or power cycling the router board as well?
Regardless… right now I have no idea WHAT needs to be configured to get the wifi side to turn back ond stay on. :frowning:


#9

I believe you have missed or misunderstood some step. For switching flytpod to client mode you dont necessarily need keyboard mouse. For you I will explain the steps again.

When you received flytpod, it was in AP mode with FlytPOD_wifi network.
steps

  1. Connect your laptop to this wifi network.
  2. Open flytconsole in laptop’s browser using the url: http://flytpod
  3. Go to WiFi settings. Scan for available wifi networks.
  4. Select the network that you want to connect to. Put in the password. Click connect.
  5. Your current page will disconnect. Also you will find that flytpod_wifi network no longer exists.
  6. After two minutes power off complete flytpod using the button on back io panel. Then plug out wall adapter and plug it back in.
  7. Connect your laptop to your home wifi network. (same network you selected in the scan list in previous step)
  8. Give FlytPOD a minute to connect your network.
  9. In your laptop browser try to open flytconsole with the url: http://flytpod
  10. If it does not work then visit your home router’s page to know the IP address assigned to flytpod. replace flytpod in above url with that IP address.
  11. If above switching had failed (because of wrong password, network issues) the flytpod will automatically switch to previous working settings. So in case flytpod failed to connect to your home wifi network then it will automatically create hotspot flytpod_wifi. If you have any doubt then see if you can see this network. If you find this network up then connect to it and again repeat steps from step 1.

You dont need to connect keyboard, mouse or enter into openwrt console all the time. It is just for debugging. In 90% cases you never need to visit the terminal.

Please try to exactly follow these steps with your mobile phone hotspot. (which means assume mobile phone hotspot to be your home wifi network).

Also as I said earlier I have personally tested this replacement kit with 3 different hotspots. And everything works without any problem at all. So I think you are either missing out something or doing it wrong way. We have been wasting too much time on an issue which doesn’t really exist. So let me help you quickly with a call. Since you have a gmail account we can connect over a hangout. If not video then audio will also suffice. Or a cell phone call will also do. I will be able to find out the exact mistake only if I am present.


#10

please see the ****** injected below

When you received flytpod, it was in AP mode with FlytPOD_wifi network.
steps

  1. Connect your laptop to this wifi network.
    ***** seperate laptop used - when connected to flytpod_wifi 'angery scanner shows the following
    192.168.1.1 OpenWrt.Lan 2mS
    _192.168.1.168 DroneGrndStn.Lan (my laptop) 0mS
    192.168.1.195 flytpod.lan . 3mS

  2. Open flytconsole in laptop’s browser using the url: http://flytpod
    ****** http://flytpod does not connect flytpod/flytconsole/ does not connect
    192.168.1.205/flytconsole/ connects

  3. Go to WiFi settings. Scan for available wifi networks.
    ****** scan works and shows my normal home wifi/lan (71GT2) I select that network and enter a password
    (noting there is no prompt box for any type of security WPA/WPA2 etc) displayed…only a network and password to connect to

  4. Select the network that you want to connect to. Put in the password. Click connect.
    ******** done…see #3 above**

  5. Your current page will disconnect. Also you will find that flytpod_wifi network no longer exists.
    ******* An acrylic Wifi scan from the desktop PC connected to the home lan (71GT2) AND a wifi dongle does indeed shows the FlytPOD-wifi disappears**

  6. After two minutes power off complete flytpod using the button on back io panel. Then plug out wall adapter and plug it back in.
    ******** I push the button and wait to here the fan on the odroid stop. I unplug power from the flytpod, wait about a minute then power it back up. blue wifi light on pod flickers after boot up. HDMI monitor on pod shows desktop with logo and a prompt box with flytpod in the text box and a log in button (I do not touch it)**

  7. Connect your laptop to your home wifi network. (same network you selected in the scan list in previous step)

  8. Give FlytPOD a minute to connect your network.
    ***** I switch wifi networks on my laptop (DroneGrndStn) back to the home router (71GT2) via wifi On my desktop machine I see the scan shows the FlytPOD_wifi is now back.

  9. In your laptop browser try to open flytconsole with the url: http://flytpod
    ***** The laptop (DroneGrndStn) will only connect to the pod if I switch it’s wifi network back to FlytPOD_wifi and only at 192.168.1.205/flytconsole (as seen in the Arcylic Wifi scanner program.

  10. If it does not work then visit your home router’s page to know the IP address assigned to flytpod. replace flytpod in above url with that IP address.
    ***** going to my home router interface (a verizon oem unit) the flytpod is not showing up as connected. An ‘Angry Scanner’ scan does not show the flytpod at all. My verizon router is configured as static adress below 192.168.1.100 with the 100 and above address all as dynamic (use DNS connect control).

  11. If above switching had failed (because of wrong password, network issues) the flytpod will automatically switch to previous working settings. So in case flytpod failed to connect to your home wifi network then it will automatically create hotspot flytpod_wifi. If you have any doubt then see if you can see this network. If you find this network up then connect to it and again repeat steps from step 1.
    ****** correct…the FlytPOD_wifi network comes back. I have tested (repeated this attempt to get the pod to connect to the verizon router 5 times now. I tested with and without MAC address filtering and even turned off requiring wpa/wpa2 as mentioned in in #3 above…client mode on the console is not asking/facilitating an encryption type)

You dont need to connect keyboard, mouse or enter into openwrt console all the time. It is just for debugging. In 90% cases you never need to visit the terminal.
****** not touching the pod other than to monitor what the pod is doing on screen and after boot up/remote config changes etc.

Finally…success…so I thought…
So… I repeated these events a few time… BUT…
I DID NOT power down or reboot the pod after setting the client mode.(#6 above) Viola’! I was able to finally connect as expected from my home network, and the flytpod_wifi network did not show up in scans.
I connected with my desktop (and laptop) via my home network (verizon router) but only at the identified IP address found in ‘Angry Scanner’ (which scans only local IPs and all open ports) I went through the licensing stuff and even played with some of the parameters/setups.
Now feeling brave, I went ahead and rebooted the pod. BUT, I simply flipped off the power, which is going to be a possible/probable event while out in the field with any UAV/UGV.
flytpod_wifi does not show up post reboot. BUT I can not connect again. Angry Scanner shows flyt.wrt.home on the home network, but no other moniker defining an access port back to flytpod.

So… if using the button on the devise, before power loss is a requirement of proper operation using the pod and not having to go through all this again… this device will never see use on any of our products. :cry:

_time you’ve spent?? he he … 20+ hrs just to find your instructions, even having redefined detailed as above, did not always work as expected. …more scenarios need to be covered/corrected. _

what I’m also concerned with is the RSSI mod is NOT in this release as installed on this replacement pod, and this revision also does not ask/configure which WPA format to use as did the first pod.


#11

Once you are connected in client mode then next time it could just be some connection issue and should be handled with a reboot. Rebooting by directly plugging out the power may result in damage to companion computer’s filesystem (and it is common with every computer I believe). There’s no harm to autopilot, which is actual flight critical element inside flytpod.

If you see openwrt connected to router but not the FlytPOD then use the desktop, keyboard, mouse and log on to flytpod. Open terminal and do ifconfig. See if it shows assigned IP on eth0. And also if you have changed anything in networking settings on flytpod undo it. FlytPOD will show a ethernet connection during regular operation. Make sure that connection is working.

And actually you shouldn’t be messing around with the default setup. Also I had asked you to try to connect to your mobile phone hotspot. That way you can make sure whether it’s your routers problem. Because the default wifi client setup will not play nicely with any router which has MAC filtering, static IP, etc. without extra configuration. So my advice is to try it with simple mobile hotspot.

I believe you have confirmed in another thread that RSSI mod is available on your replacement pod. And, an user does not need to know what encryption is used on wifi network he is trying to connect to. When you click scan, we figure out all thedetails including encryption settings(WPA PSK, PSK2, PSK mixed) (not for user though) and we automatically take care of those details for you. So don’t think its lack of functionality. It’s for simpler user experience.


#12

…getting closer here… had to build and install the arduino ros libs over again (used full vs source this time) then had to figure out where the heck the app actually was so I could add the newping libs (put in the sonar app lib dir and it found it)

no it compiled finally and seems to have DNL’ed to the arduino uno ok.
hmmmm… now have to figure out how to get hte ROS environment to run the flytos interface.

I;m more use to Linux on HPC/MPP architectures… on SBC’s these thin installs are terrible as far as development environments are concerned. I’ve written complete C.A.S.E environments automating test and factory wide automation from clean rooms to depot, and didn’t have this many issues.

…getting old I guess. 40 years of computers and they are still just dumb machines (no smarter then the programmer coding them) :slight_smile:
nuero nets are getting close…opencv and slam on parallel processing systems is a blast!


#13

replied on new thread. Closing this one.