No response so new topic! wifi client not staying/switching


#1

still having issues. I actually purchased a separate Asus n14 router to play with Openwrt, trying to figure out WHY your systems does not consistently re-acquire the client wifi connection.

this POST having the video stream up and running from post
http://forums.flytbase.com/t/no-wifi-again-back-to-squre-one/301

1- comfortable with default ‘out of the box’ setup on the pod here. (re-imaging is a no brainer these days)
2- Power up the pod wait about 3 minutes before doing anything
3- Windows10 PC- using a wifi dongle I connect my desktop PC to FlytPOD_wifi network
4- on screen in firefox it accesses flytpod/flytconsole/ without issue
5- in the console I go to wifi and select client
6 - a scan does indeed see my home router wifi - I select it and wait for the screen prompt to say it’s done
7- I wait an 3 minutes and press and hold the POD button for 2-2.5 second till the led blinks differently then let off.
8- I wait about 40 seconds then switch off power to the pod
9- upon turning on the pod, the flytPOD_wifi is still there and there is no connection from the pc/desktop router network.

10- SO… I repeat 1 through 9 above BUT using a separate laptop and the new Asus n14 router
still no disconnect of the pod wifi nor connection to the home router wifi.
11- I repeat #10 with s third laptop (internal wifi) and tested with my Iphone as hot spots to connect the pod client to
12- still no connection. (as in 9 above)

13- I have tried this repeatedly at least three times each (with variations) the pod wifi never goes away, nor does it connect with any network I select via the flytpod console. I can connect without issue from any pc (or laptop) or network to the flytpod as a AP spot. All will see the pod via wifi.

14- Using the sudo mini terminal, as well as running tests logging in as SSH root@192.168.1.1 directly on the pod, both bring up the OpenWrt terminal. Doing a firstboot && reboot from either terminal interface does not change the situation.

15- I went as far as to examine the /etc/config/networki and etc/config/system and etc/configwireless files on the pod router and there does not seem to be anything odd there with what all the openwrt documentation states. BUT I never see connect info for what was set via the flytconsole.

QUESTION… is this a possible issue with the ‘load’ v1.10 currently on my pod? how can I force an update? re-imaging did not change the issue before this last round of tests.

If there was some consistency to all this I could trouble shoot. but these procedures, that were even re-iterated to me and I followed carefully (and even repeated the boot sequences on my odroid…both auto login, both drop when the button is pushed within roughly 20 seconds. but simply the ‘client’ connect stuff is NOT working

…I need some ideas of what to look at
thanks


#2

Thanks for all the trials. This feedback is what I was asking for since long time.
Send me the complete folder on openwrt. /etc/config/

I will give you another way to test this setup. Connect FlytPOD to desktop. (Do not try this over ssh).
Disconnect from openwrt terminal access through minicom. (if you are connected to openwrt using serial connection then FlytOS wont be able to get hold of the serial connection. I hope you haven’t tested all of above cases with the serial terminal left open).
> roscd core_api/scripts
> sudo python wifi_setup.py client ssid passkey mode

replace ssid with the target wifi network. passkey with the password if any, otherwise None. Replace mode with one of (psk, psk1, psk2) if applicable, None for no aunthentication.

e.g. sample call would look like

sudo python wifi_setup.py client mYWiFi myPass psk2

Send me the terminal output when you run above command. Also send me /etc/config folder after you are done with the above test.


#3

wow… some interesting configs after testing.

1- logged in at the pod itself
2- started the lxterminal
3- ran your 3 commands

roscd core_api/scripts
sudo python wifi_setup.py client ssid passkey mode
sudo python wifi_setup.py client MyNetName MyNetPw psk2

this is the command line capture from those commands (iphone photo of the screen)

4- after executing the thee commands I rebooted.
5- after boot up the flytPOD-wifi was gone and I was able to connect to the pod from my desktop pc via my home router. So this at least did indeed reset the pod router as needed. BUT…
6- flytpod/flytconsole does not work. It now comes up as flytpod.home/flytconsole (flytpod.home as confirmed via my home network router config page as well as running an IP scanner on my network with no wifi dongle…just the wifi from the main home network router)
7- After bootup of the pod I can no longer access the openWrt interface as the 192.168.1.1 address takes me to my home network router config page and cannot (do not want to mess with?) trying to get back to the router directory structure (unless you have a way to do that simply and supply a string of commands to do so without messing up the current working config)
8- I also noticed the LED lighting difference. Facing the pod connector end, it now shows a green LED (as well as the red and blue) blinking/on down the left side of the pod (left of all the connectors…occasional blue on right side as well?)
Also now on the desktop pc screen …address flytpod.homes/flytconsole I see the version number is now 1.11 vs the original 1.10 before this round of configuration testing and after internet access became avail to the pod via my home network connection (assuming it auto-updated when internet was avail)
I’m not concerned with ‘home’ name issue unless it effects some other software call (doubtful correct?)

Only other issue now… the pod is back to not auto-login …it stops at the logo screen with a prompt box with user flytpod and an OK button that you have to press to complete bootup. I know how to fix that now though and can edit the file myself. You might want to make that the default in /etc/lightdm/lightdm.conf file (autologin-user=flytpod) in your next release :slight_smile:


#4

That sounds good. The script that you ran is used by FlytConsole to change settings of wifi router. You can try switching the wifi mode from flytconsole now. It should work. I think you must’ve been blocking serial port access earlier which was resulting in failure of the script.

The flytpod.home problem could be because of your laptop settings. On my laptop I have to use flytpod.lan, while my colleagues use only flytpod. Maybe you can look into your DNS settings. Anyway we will soon configure the auto network discovery which will solve all this IP problem.

You will not find openwrt router at 192.168.1.1 when you are in client mode. Because your home router will assign IP to it. Anyway during normal operation you don’t need to connect to openwrt router.

With this latest update we have also released a fix for AP mode. Now FlytPOD’s IP address in AP mode will always be 192.168.1.2
However this will not necessarily work in client mode, since FlytPOD can not control what IP your home router is going to assign to it.

Thanks for the suggestion. Auto login shouldn’t be a problem in headless mode though. And will be safer for most users. Anyway users who want to change it can follow your advice.


#5

Perhaps I’ll get brave this evening and try putting it back in AP mode … test the switching to/from AP/client

192.168.1.2 is my normal desktop IP with my home router being 192.168.1.1.
Might I suggest you default the CLIENT mode fixed IP of the POD be something like 192.168.1.75 or 192.168.1.111 .100 or 125 or the like. It is highly doubtful many users would have any machines numbered that high on a home/small business network.


#6

We can’t really control which IP your home router assigns to the FlytPOD in client mode. The best that we can do is to ask for a static IP but then every router could have a separate IP range, e.g. 192.168.0., 10.0.0., etc. So thats not an option too.

We leave it to user to configure their home router to assign a fixed IP address to FlytPOD.