Landing problem using LTE and RaspberryPI


#1

Hello, I’m using Pixhawk 1 and Raspberry PI to fly custom drone. I tried setting the mission using flytbase cloud. Drone is behaving well - it’s holding its altitude, following waypoints set on the map but when I set the last waypoint as command LAND the drone instead of landing is doing opposite - going all the way up it the sky. I’m wondering if I should change the altitude on LAND command or frame type? Any suggestions?


#2

frame type shoulnt matter, have you looked at the pixhawk log files?
please be aware there is a setting in Ardupilot which has the vehile climb to a certain “safe altitude” before initiating the land sequence…I dont recall the exact parameter but is in the RTL or Land section


#3

@iriol,

Thanks for your suggestion.

@Michal_Adamiak,
Were you able to solve this issue.

When the autopilot receives the LAND command, it ignores the altitude field and makes sure it lands on the specified latitude and longitude.