Issue with activating flytos - TX2 and pixhawk


#1

I’m currently having an issue activating the flytos license. I have completed my installation of flytos and am successfully able to communicate with the pixhawk. When I go to the flytconsole and follow the steps to activate the license, it will first say that the activation was successful but the moment I restart the device it will say (once again) that I have to activate the license.

The following image shows the error that I get upon restarting the device:

Any help would be greatly appreciated, thanks!


#2

Hello @jmiles, can you tell us your email id, what device are you working on to understand your problem better and we will get back to you as soon as we can!


#3

Hi,

Can you run this command on tx2?

cat /proc/cpuinfo | grep -Po ‘Hardware\t: .*’ | sed -e ‘s/Hardware\t: //g’


#4

I’m back, sorry for the late response. I’ll send you guys a message with my email. Also I tried running the command, cat /proc/cpuinfo | grep -Po ‘Hardware\t: .*’ | sed -e ‘s/Hardware\t: //g’, but nothing seemed to appear after entering the command.


#5

Hi again! I actually just tried to activate the license throught flyt console again today, and it worked! I’m not sure what changed, but thank you guys so much for your time. Have a nice day!


#6

Sending you a PM to get your profile details, to be sure everything is alright.