Intermitent connection to flytos


#1

Ok, I’ve update to v1.54 on my intel edison connected to pixhawk throug TELEM2 at 926000.
I can’t get an stable data connection on flytconsole. I get license status and can see log files. But flytConsole get intermitent connection/disconection message.
I attached log file
flyt_runlogs.log (217.1 KB)

Thank!


How to debug serial comm from Pixhawk
How to debug serial comm from Pixhawk
#2

Hi,

I went through you run log.
It seems you are not receiving data on the UART port.
There was a bug in v1.5-4, because of which it still shows valid connected status even though it is not connected. And then after some time, it shows Disconnected. This bug has been resolved and will be pushed in the new release due in few days.

Now,
I would request you to follow the steps to debug you issue:

  • stop FlytOS: run this command in terminal: stop_flytOS
  • open a terminal and look for some garbage data: sudo minicom -D /dev/ttyAMA0

Moreover, please explain how have you connected Pixhawk with Edison, preferably with images and referred documents/web-links.


#3

I’m on vacation right now. I will try it on my return.

Thank!


#4

Ok. Awaiting your response.


#5

Ok, right now I connect QGC (on my linux PC) through an USB cable to USB connection on Pixhawk. I get a good connection between Pix and QGC.
I connect TELEM1 of pixwak with 3 wire to EDISON breakout board. like this but TELEM1, becouse I have some doubt about TELEM2 port. TELEM1 port is working fine, I’ve tested with 3dr RADIO link to QGC.
I connect my linux PC (the one that is running QGC) to EDISON through WIFi (edison_ap).
I SSH to flytOS.
I run stop_flytOS, then run sudo minicom -D /dev/ttyMFD1 (what is ttyAMA0? is it UART driver on RPi?) and get some garbage

Is that setup OK for testing flytOS?

How do you want to continue?

Thank!


#6

Ok, using that setup I make some tests.
I first start with Pixhawk Serial port configured at 57600. It seems that flytOS detect autopilot, but there is some errors getting some parameters:
flyt_startup57600.log (2.2 KB)
flyt_runlogs57600.log (45.6 KB)

then I switch to 115200 and the same thing happend:
flyt_startup115200.log (77.8 KB)
flyt_runlogs115200.log (80.5 KB)

Then switch to 921600 and here flytOS seems to detect USB cable connection (?), and continue with other ports and never found my Pixhawk.

flyt_startup926000.log (4.5 KB)

then, I run stopflytos and then try to see serial data with minicom and see a lot of “garbage”.

I don’t notice intermitent connections at 57600 and 115200, but there is some message on flytconsole:

– FCU: Inefficient BaudRate 115200 detected. Set Autopilot’s Baud Rate to 921600. Visit http://docs.flytbase.com/docs/FlytOS/GettingStarted/OdroidGuide.html#configuring-pixhawk-autopilot to know more.
– TM: Wrong FCU time.
– FCU: Inefficient BaudRate 115200 detected. Set Autopilot’s Baud Rate to 921600. Visit http://docs.flytbase.com/docs/FlytOS/GettingStarted/OdroidGuide.html#configuring-pixhawk-autopilot to know more.
– TM: Wrong FCU time.
– FCU: Inefficient BaudRate 115200 detected. Set Autopilot’s Baud Rate to 921600. Visit http://docs.flytbase.com/docs/FlytOS/GettingStarted/OdroidGuide.html#configuring-pixhawk-autopilot to know more.

this is a complete flytos_startup log, it seems that some times it hangs (reboot?) trying to connect to MFD1 at 921600 (I’ve noticed that some times, during boot up, Edison seems to not responding)

flyt_startup.log (98.0 KB)

waiting for some help here!

thank


#7

Ok, I continue my testings.
I had doubt about TELEM 2 connector, so I open my Pixhawk clon and soldered 3 wires directly to the pads, then connected them to EDISON.
Now I have fully functional system!!! It seems that APM sends differents messages to TELEM1 and TELEM2, becouse connected to TELEM2, I get a list of WP and all parameters…

This are log files:

flyt_runlogs921600.log (62.3 KB)
flyt_startup921600.log (129.9 KB)

Ok, now I will start working with flytOS API, thank!


#8

Hi @elgarbe,

Great that you could figure out the issue all on your own.

You can ignore such warnings. If you find 57600 or 115200 better working (without intermittent connection), I would suggest you go ahead with this setting.

I went through all your shared logs. I could reach to one single conclusion, ‘hardware connectivity issue’. Somehow, corrupt data was received on UART terminal. The issue could have been on either Edison side connection or on Pixhawk’s side. It seems it was on Pixhawk’s side, as direct soldering has solved your issue now.

No that is not the case. It surely was a connection issue.


#9

Since you have solved the problem. Can I close this issue?


#10

yes, please, close it.


#11