How to make a package


#1

I need to add a LIDAR to EDISON/ROS.
This is the package. I just clone the repo into /home/flytos/git folder. How can I compile this package?

Thank!


#2

I mean, I can’t use catkin build…
In my ubuntu PC, after install kinetic I can use catkin config, catkin build. But on edison it seems that it is not installed…

I clone repo into git folder, then create a catkin_ws and src folder under ~, then make a symlin, then run catkin_make
I get an error asking for laser_proc. I clone that repo too, create symlink and run catkin_make.
After add several package the make proccess continue but faild with this error:

I try tha same thing on my ubuntu PC with kinetic 1.12.12. using catking build I manage to make the package.

How can I make it on EDISON?

Thank


#3

To use catkin_tools (catkin build), you have to install it separately in Edison.
You can instead run catkin_make to compile your project.

Can you please explain how and where did you create this symlink?
Also, please create a zip of your workspace and upload it over here, so that I could also take a look at it.


#4

yes, I use catkin_make but with the error on the second post.
is this the catkin tool installation procedure?
http://catkin-tools.readthedocs.io/en/latest/installing.htm

I create a git folder, then clone all package that need in there. Then create a symlink of each package to ~/catkin_ws/src then run catkin_make
catkin-make found all package and start to make them, but fail at the end.

Attached my git and catkin_ws folder:
ws.tar.gz (428.2 KB)

git folder is big one becouse I’ve tried to make catkin tools. I upload to dropbox.

thank!


#5

Yes. Have you tried installing catkin_tools via apt-get or pip, instead of building from source?

Also, I tried to build your package in my Edison and have located the issue.
Since, Edison has ros installed via ‘build from source’ procedure, the source used was quite old. It would take me sometime to release a new image with newer source.

In the meantime,
you can go to ‘bond github page’, and clone the repository. Skip this step if you have already done this.
In branch kinetic-devel, Checkout the commit: 2e9289d58b74ea995577b822a586442c583a6c10 with message C++ style.
Once done, replace this folder with already existing bond_core folder in your workspace.
I have tried it and the workspace gets compiled just fine after this.


#6

I’ve install it using pip, but can’t catking build the package´s.

I was so close! I allready clone bond project, but I’m using kinetic-devel. I will try with that commit.

Thank a lot!


#7

solved, you can close it. Thank you very much.


#8