Hokuyo LIDAR don't get recognize


#1

I’m connecting my hokuyo lidar to ARDUINO break out board for EDISON. Then run ls /dev/ttyA* expecting ttyAM0, but there is no one.
I can’t run lsusb utility, it seems that it is not installed on the system.

Any help?


#2

In fact it seems like it does not recognize any divice pluged onto full size USB connector of Arduino breakout board.
I double chek SW1 in correct position, in fact devices plugged in full size USB get power, but ls /dev/tty* did not change after plug some devices.


#3

I’ve installed usbutils from .deb package.

If I run lsusb with SW1 (of arduino breakout board) pointing to full size USB connector I get

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

No matter what device I plug on full size USB connector I get always the same result

If I move SW1 to micro USB connector side, lsusb return nothing…

Could it be easier working with a raspberry pi? I’m fighting too much and too little progress…

Thank


#4

Yes. Switching to RPi would definitely improve your experience.
Intel does not support Edison anymore, and its support community is also not active.


#5

What about flytOS on PI? what OS and what version of ROS ?

yesterday I’ve installed ubuntu, ros kinetic, my hokuyo lidar and hector slam… Now I will need mavros and pixhawk interface, but mayby I could use flytOS image…


#6

Hi @elgarbe,

Yes. I would request you to use FlytOS image for RPi. It has all the dependencies pre-installed.

Thanks.