Gazebo6 and Ros-Indigo are not support on Ubuntu 16.04


#1

Hi everyone,
I’m trying to install FlytSim on Ubuntu 16.04.
I have ODroid (running FlytOS) + Pixhawk (running PX4). I want to run applications on ODroid and simulate it on PC (which should run FlytSim). First I’m not sure if this is the right way to do this?

May main question is that when I try to install gazebo6 in Ubuntu it doesn’t appear in the candidates. I followed the instructions here http://docs.flytbase.com/docs/FlytSim/FlytSimInstallationGuide.html#gazebo6-installation
When I run this command
wget -O /tmp/gazebo6_install.sh http://osrf-distributions.s3.amazonaws.com/gazebo/gazebo6_install.sh; sudo sh /tmp/gazebo6_install.sh
It gives me > "This script will only work on Ubuntu trusty, utopic, vivid, and wily"
Is it OK to use gazebo7 instead?

Also, ROS-Indigo is not supported on Ubuntu 16.04 as the ROS installation guides says
"ROS Indigo ONLY supports Saucy and Trusty"
Can I then use Ros-Kinetic instead?

Thanks


#2

Hi @SalahuddinAsh,

The documentation is ONLY valid for Ubuntu14.04 & ROS-indigo. If you are running Ubuntu16.04 and have installed ROS-Kinetic, then Gazebo7 comes pre-installed with ROS-kinetic(ros-kinetic-desktop-full). Kindly follow this forum post for how to install FlytSIM(for ROS-Kinetic) on your computer.


#3

Hi @srv ,

Thanks for the link, it’s really helpful. I followed the instructions there and when I run this command at the end
sudo $(rospack find core_api)/scripts/start_flytOS.sh --sitl
It worked but with the following errors:
ERROR: cannot launch node of type [rosapi/rosapi_node]: rosapi
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/flyt/flytos/flytcore/share
ROS path [2]=/opt/ros/kinetic/share
and
[flytsim/rostful-14] process has died [pid 24579, exit code 1, cmd /flyt/flytos/flytcore/lib/rostful/devserver -p 9090 -s tornado __name:=rostful __log:=/home/salahuddin/.ros/log/aefccd72-b968-11e6-afd0-74d4359d79dc/flytsim-rostful-14.log].
** log file: /home/salahuddin/.ros/log/aefccd72-b968-11e6-afd0-74d4359d79dc/flytsim-rostful-14*.log**
and
[ERROR] [1480777005.149809625, 1.608000000]: call takeoff API(or let the vehicle reach takeoff altitude) before sending next position setpoints

And Gazebo started with a drone in the middle.
Is it normal?

Thanks


#4

It seems you have not installed a dependency, ros-kinetic-rosbridge-suite

Can you post the error thrown just before the above message, if there is one.

thats OK for now.

yep this is what is supposed to happen.


#5

@srv
Well, now it’s working after installing this dependency. There was another missed dependency that the terminal asked me to install and I did but I don’t remember what was it.
I hope you add this missed dependency to the install bash. And it would be nice to update the DOC.
Many thanks


#6

Hi @SalahuddinAsh,

well the dependency: ros-kinetic-rosbridge-suite , is indeed mentioned in the install script. I wonder why it didn’t get install in the first place. For documentation, update work is underway. Thanks.