Followme - constant disconnect


#1

Hardware being used:
Pixhawk 2.1 w/ Intel Edison(flytos installed)
Mauch battery system w/ 2 6S lipo
Logtech c270 webcam
5 volt powered OTG USB powering the webcam

I have flytos 1.56 PE installed on the Intel Edison in my Pixhawk 2.1. My entire system is running as it should I am able to go to Flytconsole and everything loads perfectly and displays all telemetry quickly. In flytconsole I never get disconnected from my FC. FlytOS is rock solid in flytconsole including the video stream. I have left it running for a half hour with out any interruptions. So when I switch to followme at first eveything seems great i stay connected , video shows so press start and i get a message “object tracking started” then 2 seconds later my FC disconnects. 5 seconds later i get a “failed to contact flytpod” message . Then my FC connects again and then 5 seconds later disconnects. Seems like an endless cycle and never seems to work and eventually my video freezes. Please help i just cant seem to figure this out. I would upload my logs but it says new users cant upload logs.


#2

I will test this on my end and will get back to you.


#3

#4

flyt_runlogs_2018-04-09_00-20.log (102.2 KB)
flyt_runlogs.log (111.1 KB)
flyt_startup.log.2018-04-08 (19.6 KB)


#5

So I’m still trying to figure this out…I can’t find anything about anyone with a working “followme” on a pixhawk 2.1 Edison. I reflashed Edison with the old 1.41 version. I then made sure I was able to get telemetry and steady connection in console. I was also able to get a good steady video. I went to the followme section and the same problem happened. I tried the same after rebooting without the camera attached and got the same disconnects after starting object tracking. I set my serial 5 baud rate 921600 and to mavlink… Is there something I’m doing wrong on the pixhawk side? Very frustrating


#6

hi @seanch123,

I am sorry and I understand your frustration.
Unfortunately, I could not take a look at the issue yet. I would try to reprioritize my work and take this up as soon as possible.


#7

Hi @seanch123,

So I tried to replicate the scenario on my laptop.
I installed the latest FlytSim in my machine and configured it in PX4-SITL mode (as it supports object following). If you would like to try it out, reply on this thread.

I also installed the latest Aero FlytOS Debian on my laptop and I cannot replicate the issue either. When I connect Pixhawk to my laptop, the behaviour is just fine.

I am now trying out RPi, and will update the result soon on this thread.


#8

I believe the issue is with excessive CPU usage by Object Tracking module which Edison is not being able to cope up with.

It would be great if you could confirm these observations as well:

  1. Open the Follow me web app.
  2. Make sure the app has loaded with correct ‘Connection’ status.
  3. DO NOT press/click on ‘start’ button, and notice if the ‘Connection’ status flickers or starts behaving the old way.
  4. Once satisfied (you should not see any flicker), click on ‘Start’ button and you would observe the same old behaviour once again.

Unfortunately, I would have to dig deeper to resolve this issue, as this should not have happened in Edison. We had tested the code before on Edison (though a long time back), and it was working just fine.


#9
  1. I opened the follow me web app
  2. page loads and status turns to connected and stays connected. I left it for 5 minutes and it never even flicker. Rock solid connection.
  3. once i click start button it stays connected for 10 seconds and then once again begins to disconnect and then connect continuously.

I would like to say what I have observed…I re-flashed the older OS 1.41 and compared to 1.56 the 1.41 is so much faster responding not sure if there is anything new contributing to CPU load.

Also after re-flashing a couple of times to do some trail and error i notice now occasional connection disconnection in flytconsole. Also for some reason my ssid of the edison hotspot should be “edison_ap” now its “EDISON-00-00” and then “EDISON-D2-9C”.

Seems like strange behavior now with the OS after re-flashing 5 times


#10

Hi @seanch123,

Thanks for sharing the detailed observations.

This is what I had expected. As stated before:

I have added this task to our bug-fix backlog. We should soon release an update on this.

‘so much faster’! Does FlytConsole load quicker? What did you observe, that led to this conclusion?
You can run ‘htop’ and check the system profile in either case, to understand the CPU usage differences between the 2 versions. I would anyway try to test it on my end.

Yes. Your observation is correct. Our documentation needs to be updated for Edison. With 1.4-1 image, I added this feature wherein when you flash the Edison board, it adds a random ‘string’ (in your case it was ‘-D2-9C’) at the end of SSID (‘EDISON’) so that users do not get confused if they have multiple Edison boards.