FlytSim : Snapshot


#21

Hi,

Within your gazebo gui, enter ctrl+t and select the camera topic. Check if you can visualise any video. Which version of Gazebo are you using?


#22

Hello,

I can’t find the camera topic under the gazebo gui ,

the gazebo version is 2.2.3.

Thanks


#23

Hi,

Under topic selector, look for gazebo.msgs.ImageStamped. Click on the subsequent topic /gazebo/default/iris/iris/camera/camera_1_link…

If you cant find this topic, then I am afraid, but there is some huge problem. Try re-installing FlytSim. Try installing it in some other machine.


#24

Hi,

I got the topic but it shows no image. Please check the screenshot.

Thanks


#25

Hi,

check whether you have the file libgazebo_ros_camera.so at /opt/ros/indigo/lib folder.
Have you tried reinstalling FlytSim??


#26

Hi,

yes the file libgazebo_ros_camera.so is present at the given position.

Also I have reinstalled the FlytSim version 0.3-1

Thanks.


#27

Hi,

Is there a issue regarding the opencv that has been installed or anything else.

Please let me know.

Thanks.


#28

Hi,

Could you please send a detailed report on the methods you used for installing ROS/FlytOS/OpenCV (commands you fired, webpages consulted, programs installed).

Also report on any and all dependencies that you have installed on the way.


#29

Hi,

On Mac machine I have installed the virtual ubuntu 14.04 using virtualbox.

For installing ROS below is the link which I have followed step by step:
wiki.ros.org/indigo/Installation/Ubuntu

For installing OpenCV below is the link
samontab.com/web/2014/06/ins … 14-04-lts/

For installing FlytSim below is the link
docs.flytbase.com/docs/FlytSim/F … Guide.html

Thanks.