Flytsim-pe_1.1-1g_amd64.deb: Unable to install


#1

Hi, I downloaded flytsim-pe_1.1-1g_amd64.deb from flytbase.com.
But I am unable to install it, I get below error. Could somebody help ?

$ sudo dpkg -i flytsim-pe_1.1-1g_amd64.deb
Selecting previously unselected package flytsim-pe.
(Reading database … 262640 files and directories currently installed.)
Preparing to unpack flytsim-pe_1.1-1g_amd64.deb …
Unpacking flytsim-pe (1.1-1g) …
Setting up flytsim-pe (1.1-1g) …
ln: failed to create symbolic link ‘/opt/ros//bin/flytlaunch’: No such file or directory
dpkg: error processing package flytsim-pe (–install):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
flytsim-pe

Regards,
Shakthi


#2

Did you follow the steps 2 and 3 properly shown in the link : http://docs.flytbase.com/docs/FlytOS/Developers/FlytSim/FlytSimInstallationGuide.html
Do you have these following lines in the /etc/bash.bashrc file on your computer:

source /opt/ros/kinetic/setup.bash
export PYTHONPATH=$PYTHONPATH:/flyt/flytapps:/flyt/userapps
source /flyt/flytos/flytcore/setup.bash
source /flyt/flytos/flytcore/share/sitl_gazebo/setup.sh
export CPATH=$CPATH:/opt/ros/kinetic/include


#3

Thanks Zubin. It worked. I didn’t follow steps earlier.