FlytSim: License File Invalid


#1

Hello,

I have recently installed the FlytSim v0.2.1 Docker image onto my linux computer, and I set up a container to use nvidiagraphics. Everything was set up correctly, I used the setup.sh script to do so. I then ran the container, using start.sh, and activated FlytOS through the console. This is where my problem comes into play. Despite FlytOS recognizing that it has been activated, I get the following error in the log when starting FlytOS within the container:

lsblk: dm-0: failed to get device path
FATAL [LIC] license file invalid

Because of this, the navigation_api does not start up from the core_api package. When trying to start it manually, using rosrun, it throws the same error and stops.

Does anyone know what can be causing this? I have been banging my head against the wall trying to figure it out.

Please let me know if you need more info. Thank you.


#2

Well I found the problem. I never even thought that this could be a problem. Since my home directory is encrypted, the swap space is also encrypted. This is why lsblk was unable to get the device path. I unencrypted my swap space and then reactivated FlytOS in FlytSim. That solved my issue.


#3

Hi @James_Mchugh,

Thank you for letting us know how to solve this issue. We never tested with encrypted space!
Will add this to documentation.

Thanks.