FlytSim Docker Working with rospack error as well as can't connect to master


#1

I am able to run the FlytSim Docker on my SurfaceBook. I am running into the issue though of the following:

I receive the [rospack] Error: package ‘core_api’ not found problem. I have following all instructions of installing and other post about this put still have a problem.

I am also trying to run the demoapp1 when the FlytSim is running, and i get the error that is can’t connect to the master. Could some please help me with this, as i am trying to this on my custom drone built for facial tracking in autonomous missions.

thanks,


#2

Hi @juvillan,

How have you installed FlytSim? Please share the link that you followed for the installation.

Are you installing the FlytSim-Docker or FlytSim-native?
What is your Host OS? (Mac/Windows/Linux)

Share the screenshot, when you launch the FlytSim instance from the terminal.


#3

There were a lot of things messed up, so i uninstalled everything and started from scratch! with ROS and FlytSim-Docker.
The system that i am installing this on is Linux. I used the installation guide for FlytSim-Docker found here:
http://docs.flytbase.com/docs/FlytSim/docker/setup.html

Once i installed everything again, it seems like it is up and running. Attached is the screenshot of this. But when i try to execute my onboard cpp program, or the demoapp1, it doesn’t run.

I also checked the rosnode list, and it looks like all the services are running correctly as well. So i am not sure why i cant get my code running on the Sim so i can test out before deploying.


#4

sorry for the issues faced.

Everything seems perfect.
But you have not mentioned, how are you triggering the demoapp1 or any other app.
can you share a screenshot of the same.

I tested it right now, and I was not able to replicate your issue.


#5

Okay so I have everything up and running, as you see. The following is a screen shot of the output of running demoapp1.

The link below is what i followed to execute the demoapp1:
http://docs.flytbase.com/docs/FlytOS/Developers/BuildingCustomApps/OnboardCPP.html

I have also written my own custom app as well and below is the results to this. I also followed the documentation online to build it and make sure that all libraries are linked. And you can see in the picture below that it build successfully with no errors.

I see what the error is, and so i looked at the “/etc/bash.bashrc” as well as the “~/.bashrc” and here are the results for this, and i believe that these are configured and correct.

Please let me know what i am missing here, but based on all your documentation, i should have everything setup correct…I hope.


#6

Hello Justin,

I am sorry but it does not make much sense.
FlytSim is running inside a Docker container, and you seem to be running your apps on your host OS. That is simple not possible in the current configuration.

Also, have you also installed the FlytSim-native version? The fact that you are able to compile your demoapp outside the docker container makes me think likewise.

How to build and run the cpp demoapps for FlytSim-Docker:
This link should help with that. You have two options:

  • Either use openshell.sh script to open a shell inside docker container, where you compile and run your executable.
  • Or use the WebIDE which is packaged inside FlytSim-Docker to gain access to the container’s file system and terminal in your browser. Click here to know more.

You have a THIRD option as well, where you get access to FlytSim container’s network access, without entering into shell/terminal of FlytSim container. It works on my machine (Ubuntu 16.04) but has not been tested much.
For this,

  • Open docker-compose.yml file
  • Comment out/remove hostname: flytsim and add network_mode: "host"

I have attached the updated docker-compose file.
docker-compose.yml

Suggestion:
Do not use sudo ./<appname>. If you need sudo permission, run this command to open a new shell with root access: sudo -s and then run your command: `./<appname>

In case, you would like us to improve our documentation/product (flytsim), please give us your valuable suggestions/feedback based on your understanding.


#7

Okay perfect!!

I am now up and running and executing the demoapp. What i am going to do is just run the openshell and they execute my programs there for testing before deploying onto my TX2 board for live testing.

When i open the shell thought i am in the flytsim userspace. Where would i put my custom files so i can see them and execute them. As of right now i cant figure out how to get my custom apps once built in the right location for running.


#8

This doc should help you in installing your demo app.

To execute the app, you can either do it via the terminal or call exec_script API.


#9

What are the parameters that I need to change on the Pixhawk, in order to communicate from Jetson TX2. I am using the TELEM2 port which is correct and have it plugged into the UART.


#10

Please checkout this guide.
Also, try to start a new issue, in case your query is unrelated to the thread. Better for the community.


#11

Thank you. Will start a new thread about this.


#12