FlytPOD OS license activation invalid


#1

Last week, I have updated the FlytOS to V 1.5 PE. After updation of OS, the console doesn’t shows the OS activation, status. So, I tried to activate the OS using the license key (available in the registered account owned by Mukil Babu). But it shows invalid key and also in the ESC and motor calibration tab, it shows 'This widget works only with FlytPOD. I have enclosed the image for your perusal.

Added with, I would like to bring out an issue, which we were facing during powering of flytpod. When the flytpod is connected with the battery, usually the heat sink fan starts and the flytpod gets powered ON with breathing bluelight. But sometimes, the heat sink fan doesn’t starts and LED indicates breathing blue. I have also tried to disconnect and connect all the connections.But still the problem occurs. After few try, the heat sink fan starts. What could be the reason for this?? Kindly provide me the solution.

Kindly consider this as urgent and reply ASAP. Pls revert me back for any information.

Thank you and regards,
Arun Ravindran


#2

Hi,

License Activation issue: Did you try to clear your browser cache?

Please explain further.

Asking my team to verify this issue.

There is absolutely NO relation between a breathing blue RGB led and the starting up of heat sink fan. But on the other hand, heat sink fan usually starts up when odroid boots up. So make sure that the odroid boots up, when the fan is not rotating.

Thanks.


#3

Hey arunravi,

About the ESC calibration tab, we are looking into the bug and the software team will soon update you with the solution.

Regards,
Karan Uderani


#4

Hi srv,

  1. Yes, I tried by clearing the browser cache and it did not work.

  2. In previous version, when I click the license option in the console. It shows the status as ‘license activated’. After updating the OS, the licence activation status is not found. Kindly check the image attached in the previous trail. When I tried to activate the OS with the existing license key, a error message pops up “invalid key”. We are in the phase for the readiness of our flight test (5½ m span). I would request you to kindly solve this activation issue ASAP.

  3. Regarding heat sink fan start up issue, how to make sure that odroid boots up. Because, we are facing this issue repetitively.

Thank you,
Arun


#5

Hi Uderani,

Thank you for the update.

Regards,
Arun


#6

Hi,

But the pictures suggest that you have an activated device (bottom right corner shows flytos personal license with green badge)

Please attach flytos startup and runlog as mentioned here.

The easier solution would be to simply connect hdmi monitor to hdmi output port, and check if it boots up even if fan does not start up.


#7

@arunravi

In the updated UI of FlytConsole, you would see the green badge with logo of FlytOS indicating your license as personal or commercial. This itself indicates that the device is activated. When you again entered the license key, it should give a success message. You seem to have two devices in your account, so please make sure you enter the key for the same device else it will say ‘invalid key’.

Regarding the ESC calibration issue, the bug is now resolved and we are pushing an update. We will inform here once the new version is available and then you can connect your device to internet and update FlytOS.


#8

Hi,

Thanks to you, we have fixed this bug, and i request you to connect your device to internet to let it auto update itself.

Thanks again.


#9

@srv
Please find the start log and run log attached.
flyt_startup.log (5.5 KB)
flyt_runlogs (1).log (57.0 KB)

@pradeep

Thanks for the information regarding the activation status. I have tried with both the licence key, still it shows invalid key.


#10

@arunravi
Thanks for the logs. From the logs we can see that the device is unable to connect to Internet. Your device is already registered/activated and license is valid. However, when you enter the license key again, the device needs internet to connect to server for validating the license key. Since it fails to connect, you get error message and your previous license is retained.
BTW, the key you entered first (as per the logs) is the correct one for this device.

Please check and establish internet access on the device and then you can retry. You will need to do it anyway to get the updated version of FlytOS i.e. 1.52


#11

@pradeep

I have updated the flytOS to V1.5. Still the problem exist. I have attached the image for your concern. Please take necessary action and do the needful.


#12

Did you try remove browser cache, or reload the webpage with ctrl+shift+r.


#13

@srv

After removing the cache, the console is working fine. Problem solved. Thank you @srv, @pradeep & @uderani.


#14