flytPi+ 3DR Solo Parameters


#21

The log suggests that FlytOS was running for about an hour, and within that time frame, it stopped receiving the heartbeat from Solo 4 times. This is definitely an issue, but:

It seems the issue has now shifted to Solo not sending its acknowledgement within the timeout, due to which APIs respond with a failure status.

Is it possible for you to just get Pixhawk + GPS (not a full drone), for your easier testing? Of course, you won’t be able to fly, but you could easily go through with static testing.


#22

Also, does Solo RC provide a UART output?
Can you connect Solo RC’s USB output to USB of Raspberry Pi and check if you are receiving any data on USB port?

Edit: I think this is a feasible solution, which we missed. I think One can connect a tablet to Solo RC, run ‘Tower App’. If that is possible, the above solution should work as well.


#23

We do run static tests, with the solo without props, but we get the same issue. We don’t have much experience in hardware, so if you could send a link / tutorial on how to achieve a configuration that works without a full drone, we could give it a try.

Also can we somehow increase that timeout? is there a setting for it? Thanks

I will check about Solo RC USB connection - but I don’t think there is one.

Also regarding the Tower app, it should work with the solo, but would that help in this case? Would the flytOS talk to the tower app, instead of the solo directly? or we connect the tablet / phone via USB to flytOS? (I’m trying to understand what solution you were thinking of).

Thanks.


#24

I am asking you to connect RC to FlytOS running device (RPi) via USB.