Flytos is not activating on Odroid XU4(kernel 4.9.34)


#1

I have installed FlytOS(using the FlytOS image) in Ordroid XU4. Initially when installed I was able to activate it successfully but later when I upgraded kernel to 4.9.34(in order to install librealsense library which requires higher kernel version) I was not able to activate it. It shows error invalid key or device id.

I have tried to solve it by using solutions in below link FlytOS cannot activate but with no success.I also tried to generate new license key but still it shows the same “invalid key or device id”.
Can someone help us.


#2

Is your device connected to internet in the first place?

Run the following commands in odroid’s terminal:

ifconfig

ethtool -P $(ls /sys/class/net/ | grep -E 'enp|eth|eno|enx|wlp|wlan|wlx') | grep -Po 'Permanent address: \K.*$' | sed s/://g

#3

Have you installed the latest odroid image with kernel 4.9, or just updated your kernel from 3.10 to 4.9?

It is highly not recommended by odroid to just upgrade your kernel from 3.10 to 4.9, and instead install the latest odroid4.9 image. Once their image is installed, follow this guide to install FlytOS.


#4

I tried this method ie installing latest odroid4.9 image and then followed the guide. It works.
Thanks for the help.


#5

Great. Happy to help.


#6