FlytOS Has Problem For Connecting to 3DR Solo


#1

Hello, I am connecting FlytOs which is in Raspberry Pi 3B+ and i am using accessory bay connector for 3DR Solo. it has problem to detecting autopilot.


#2

#3

it was connected. and then i put everything together it is not showing anything right now


#4

flyt_startup (1).log (38.2 KB)


#5

As you can see around wed jan 23 9:30 2019, it detect autopilot.


#6

How have you connected the Solo with RPi ?
Moreover, it seems you have configured Mavlink version as 2 in APM Solo. I would suggest to use 1, as we found with Solo setting mavlink version as 2 caused issues.


#7

Hello,
I am using mavlink 1 and baud rate to 57. so it is completely fine with system. again thank you.


#8

Sorry for the delayed response.

Please provide me details on this.


#9

i connect using UART connection using Accessory Bay. i send more detail document in the Mail too.


#10

Hy i set mavlink to 1 and also 921 as you mention to document, it was connected last time but, there is few error. i will send you the log too can you look into it


#11

flyt_startup.log (18.8 KB)


#12

Hello @srv-admin,

When i open the drone i got the signal, but after assemble it. it is not sending any signal , and it happens twice. and also i tried to check UART port using " sudo minicom -D /dev/ttyAMA0"
But i am not getting any signal, even can you check your email. i send you detail.


#13

Sorry for the delayed responses.
I would suggest you to first make sure you can connect QGC or Mission Planner with Solo reliably, before trying to integrate FlytOS.

Correct me if i am wrong, but Solo is quite old and the software team has stopped pushing updates. There are tonnes of bugs/issues with the system and unreliable communication is one of them.

As I said before, I would suggest you to make sure Solo can connect to QGC or Mission Planner. Once done, it would make it a lot easier to integrate it with FlytOS.


#14

I connect solo with mission planner as well as QGC. it connect completely fine. but when we try to connect solo using Accessary Bay and RPI3B+. it connected 3-4 time and it was stable connection. i used serial 2 and mavlink 1 with 57 baudrate. because when i see flytlog it connected to 57 with flytos. so there is some issues, when i put the drone back together. and the solo, We have it for long time and if we can integrate this one then it will be usable. so i will give you more updates as soon as i solve some of the issues.


#15

Was this via Accessary Bay?


#16

i connect pix hawk using usb cable to mission planner.


#17

and when i set baudrate to 57600 and mavlink1 in serial 2 link it has stable connection, but when i connect with 921600 and mav link1 it disconect and connect. and i am getting this msg.


#18

#19

This is just a warning message in case you forgot to change the baud settings. Setting baud rate to 921600 is NOT a must, and for general use cases where one does not need high frequency data from autopilot, setting baud rate to 57600 is just fine.