[FlytOS] [Edison] Response of shell is very slow


#1

Hello Flyt team, I have flashed FlytOS in Intel Edison board as per video: https://www.youtube.com/watch?v=LHMF8peY2MY

After that I removed power cable, which resulted in reboot.
I could see command prompt. But response time is very slow. The characters I type are not properly read by the shell.
Could you help what may be the reason for this issue?

Also, How to setup WiFi connection in FlytOS ?


#2

Hi,

It is indeed quite strange. Can you try changing your usb cable?

Assuming, you want to configure edison’s wifi, I have written down steps to do the same. Kindly inform me if you you meant something else.

Steps to setup Edison’s wifi connection:

By default, edison’s network will start in AP/HotSpot mode, with
wifi-ssid: "edison_wifi"
password: FlytPOD123

If you want to connect edison in client mode to connect to your office/home router:
Open this file: /etc/network/interfaces

Default content of the file would be:

interfaces(5) file used by ifup(8) and ifdown(8)

auto lo
iface lo inet loopback

auto usb0
iface usb0 inet static
address 192.168.2.15
netmask 255.255.255.0

#auto wlan0
#iface wlan0 inet dhcp
# For WPA
#wpa-ssid ssid
#wpa-psk password
# For WEP
#wireless-essid Emutex
#wireless-mode Managed
#wireless-key s:password

And the following 4 lines are for when using hostapd…

iface wlan0 inet static
address 192.168.42.1
netmask 255.255.255.0

Now, comment out the section under And the following 4 lines are for when using hostapd...
and uncomment following 4 lines:

auto wlan0
iface wlan0 inet dhcp
# For WPA
wpa-ssid ssid
wpa-psk password

Replace ssid and password according to the router you want edison to connect to.

Once done, run the following commands in edison’s terminal:

sudo systemctl disable hostapd
sudo systemctl enable wpa_supplicant
sudo reboot


Pixhawk2 Intel Edison Activation issue
#3

Also, try considering flashing again.


#4

Thank you so much. I’ll follow the steps.


#5

OK… I shall try re-flash.