FlytOS 1.34b on Pi3, with Pixhawk loaded PX4 firmware is not displaying GPS, Flight mode in Flytconsole whereas with Ardupilot firmware its working fine


Hi, pls find below as required. In FlytOS1.31 there was no such issue


Very strange, it started working ok after few power cycles.

PX4 Firmware on Pixhawk connectivity issue with FlytOS-Pi3 (some times work some time not)

PX4 Firmware on Pixhawk connectivity issue with FlytOS-Pi3 (some times work some time not, this time it is 4th power cycle when it not worked).

One thing I have observed that MAVLink Telemetry on QGCS @TCP also does not work in the situation when all tabs are not well detected with PX4.


When you change your autopilot from APM to PX4 or vice versa, FlytOS takes some time to get working. Have patience, and leave it on for 3-4 mins. Mind you, you would only need to wait once. This is a known bug and we are working on it. But, once it connects to PX4, the connection would remain stable, even after multiple reboots.

If flytconsole shows Disconnected, QGC won’t work too.

Also, I hope you understand, that after booting up RPi, please wait for around a minute or two, before expecting Connected status in FlytConsole.


Hi, Thanks for the continued support. I always waited for around 4-5 minutes after every reboot but got it working OK hardly once out of 20 reboots.

With Ardupilot firmware on the same Pixhawk board, no such issue observed even on repeated reboots.
For the time being, I am sticking only to Ardupilot Firmware and shall wait for the fix for PX4.



Do you have any preference for APM vs PX4? [quote=“narpat007, post:6, topic:425”]
For the time being, I am sticking only to Ardupilot Firmware and shall wait for the fix for PX4.

Yes, please do this. In the time being, i would do some stress test on RPi with PX4, and try to figure out the problem.


Hi, the only preference is that on the same board when loaded with PX4 firmware, there is huge huge connectivity issue while with Ardupilot firmware on the same Pixhawk board, I did not observe any issue so far.


By this I meant, Which autopilot would you like to work with? Have you worked with either of them before?


Hi, I have very long working experience with Ardupilot, and very rarely used PX4 firmware on Pixhawk board. But I can think of using PX4 firmware too.



As such we support both PX4 and APM equally (except FlytConsole mostly supports PX4). All our APIs work with both PX4 and APM. So you can very well work with APM for now.

Unfortunately I have not been able to reproduce your issue on PX4.
Can you please do the following:

  1. Run PX4 on Pixhawk
  2. SSH into RPi3
  3. Stop FlytOS by running command : stop_flytOS
  4. Launch FlytOS by running command : launch_flytOS
  5. Copy the entire output thrown in terminal, into a file
  6. Upload the file over here.

Hi, will try and update once back home.



Hi, Pls find attached the same.FlytOS-Pi3 with PX4 firmware on Pixhawk Board - log.txt (81.8 KB)


Well, was flytos working fine at the time you registered the log? with flytconsole showing connected.


Hi, yes, I observed in the FlytConsole that it was working fine at least till the next reboot


Hi, it seems, I got a temporary workaround of this issue and that is while the Pi is on and I have waited for some 3-4 minutes the give power cycle to Pixhawk running PX4 firmware then all the tabs in the FlytConsole become active.


Great that you have found this hack. I think even we faced a similar bug, and it was solved this week. Your problem should be solved in our next release.


Hi, thanks for the support. Is the CSI cam support been resolved ?
I am still waiting for the support to get me HD video at ground.


It is in our pipeline. Should be released by the end of next week.


Thanks, I shall be waiting for that



For others facing the same problem,


Hi, I have already replied in another post.