FlytCloud WebSocket Error


#1

Failed to requests the Cloud API with https://dev.flytbase.com/websocket for websocket call 。
Error info:
Failed to construct ‘WebSocket’: The URL’s scheme must be either ‘ws’ or ‘wss’. ‘https’ is not allowed.

Is there a ws or wss address for websocket call?


Troubleshooting when using virtual drone
#2

You can use the same URL with ‘wss’ protocol for websocket, for example: wss://dev.flytbase.com/websocket


#3

Thanks, My request info is :
{Authorization=Token 776b0a03b87cb935a8ab74a48be5ecaab23638bc, Connection=Upgrade, Host:443=dev.flytbase.com, Sec-WebSocket-Key=d8/nHjMw/FjJcwFhJGPuQA==, Sec-WebSocket-Version=8, Upgrade=websocket, VehicleID=v3mnG3Zw}

But the websocket handshake failed with state NOT_MATCHED. Is there any example for flytcloud websocket requests?

PS:
I had tested websocket in local FlytSIM without authorization and the app works fine.


#4

Have you enabled internet access for mentioned vehicle using given access token via FlytCloud’s Developer settings?


#5

Yes, I had enabled the access status. Can you use the token 0d7068c4e18bfa74e8e8135a1c62648e559338e7 and the vehicleID v3mnG3Zw to subscribe the flytsim
state using flytcloud websocket ?

PS :
I’m using Java-WebSocket( version 1.3.4) as my client , and the construct method is below:
/**
* Constructs a WebSocketClient instance and sets it to the connect to the
* specified URI. The channel does not attampt to connect automatically. The connection
* will be established once you call connect.
* @param serverUri the server URI to connect to
* @param protocolDraft The draft which should be used for this connection
* @param httpHeaders Additional HTTP-Headers
* @param connectTimeout The Timeout for the connection
*/
public WebSocketClient( URI serverUri , Draft protocolDraft , Map<String,String> httpHeaders , int connectTimeout )


#6

Can you please go to my.flytbase.com, verify that the status corresponding to your drone is indeed ‘Green’ and then click on ‘Launch Console’ button at the right side.

The above button would open live.flytbase.com. Please verify if the site can successfully connect to your drone and shows a ‘Connected’ status.

Moreover, the network you are connected to, does it have an outbound firewall which prevents you from accessing sites not running on default port 80 or 443?