Flashing Flytos Image on eMMC vs SD card


#1

I wonder if anyone else experienced this issue trying to flash Flytos image to eMMC instead of SD card on Odroid? I have tried this on 8 different eMMC cards and 6 different Odroids, 4 card readers, on Windows and Mac and always get the same result - Flytos would not boot from eMMC, but the exact same image on an SD card will boot just fine.

Just to make sure you have all the info here’s my procedure:

  1. Use branded, recommended micro SD card reader and insert eMMC on adapter
  2. Erase with SD card formatter (write zeros to it)
  3. Use Etcher to flash the Flytos image and let it check the card afterwards
  4. Insert the card/eMMC and move the switch to respective memory used

Like I said - never boots from eMMc and always form SD card. Am I missing something?
Here is the screen I would get with eMMC:


#2

Hi,

It is indeed strange. We will look into this issue and get back to you as soon as possible.

Moreover did you try to flash the odroid’s standard image to your eMMC?


#3

I am not being able to replicate your scenario:

So here’s what I did,

  • installed Etcher on a Windows Laptop.
  • Downloaded Odroid’s image from the official download link.
  • attached eMMC to a SD card reader and inserted it into the Windows laptop.
  • Launched Etcher and flashed the SD card.
  • Once Ether flashed and verified it, ‘safely removed’ the Card reader.
  • Attached the eMMC card to Odroid, flipped its Boot switch to eMMC.
  • Made sure no SD Card is inserted in the SD card slot of Odroid.
  • Powered up the board.
  • It may not have booted up correctly on first power cycle.
  • I removed the power and inserted it again, and this time it booted just fine.

Once you have flashed the eMMC, did you insert it back to your laptop and verified if the laptop is indeed showing 2 extra drives. Is the bahaviour same if you insert SD Card in place of eMMC into your laptop?


#4

Thanks for a quick answer. So I followed the same steps - downloaded the image again from your link, tried once with previously downloaded flytos and once with the newly downloaded.

Erased the eMMC with SD formatter (overwrite format)
Flashed the eMMC with Flytos image
Checked that it shows as a drive on Mac
Put it into Odroid and plug it into power

Did this twice, no luck it still gets stuck on exact same screen.
I tried linux eMMC and it boots right away.


#5

Hi @Sudija,

I did not do this step.

It should show 2 separate new drives when you insert the eMMC. If it is showing just one drive named ‘boot’, then there is a problem while flashing.

what do you mean by this? The standard Odroid’s image?
Moreover, the image that you have shared, is that of your ‘linux eMMC’ ?


#6

The image attached is the boot screen of Flytos flashed eMMC.
When I flash ODroid linux image it boots up.

I am not showing two separate drives. That might be the problem. It’s only one called boot.
Why do you think this is happening? Something else that needs to be done to the eMMC to prep it for the image?

THANKS!


#7

Did you get this straightened out? I’m having the same issue!


#8

No. We could not replicate this on our eMMC cards.

If you are facing the same issue, just flash the latest Odroid Image (Ubuntu 16.04 / Xenial) and follow this guide to setup FlytOS on Odroid.