Flash edison problem


#1

Hi, I’m trying to flash an intel edison with mini breakout board.
I run ./flashall.sh and it tells me that plug edison and reboot the board. How can I reboot the board? is it with SW1 switch?
I have the intel yocto image flashed, could it be the issue?

Thank


#2

$ ./flashall.sh
Using U-Boot target: edison-blankcdc
Now waiting for dfu device 8087:0a99
Please plug and reboot the board
Timed out while waiting for dfu device 8087:0a99
DEBUG: lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 8087:0a2a Intel Corp.

it seems that the flashing tool is waiting for 8087:0a99 but my edison is in 8087:0a2a. why is that?


#3

I’ve change USB_PID on the .sh script and nothing. So I think that it could be for having an image flasehd?


#4

Ok, I’ve manage to flash the edison. I don’t know why I have to reboot my computer. Then I plug USB cables and ubuntu detect a new volume called Edison. Now I run the script and it works fine


#5

Hi,

It is indeed strange. ‘Edison’ volume should have been detected in the first try. Few weeks back, I had verified with my edison, using yocto image and it worked just fine.

I would do this again.


#6