Flaperon configuration - Fixed wing


#1

Hi,

Currently I am working on fixed wing aircraft with flaperon configuration. I have one servos for each aileron control surface. One servo is 180deg phase shift from another servo. Using Y connector, I will connect it to the flytpod RC channel. For setting up the flaperon config on the same servos, how should I proceed.??

Thanks in advance,
Arun


#2

Please tell us more about the setup. Which TX/RX are you using? As servos need to run in opposite direction, Y-cable won’t work.


#3

I am using a Futaba T6J transmitter and R2006GS receiver.
As mentioned in my previous post, my ailerons are powered by two separate servos. They are mechanically assembles to the control surfaces (ailerons) such that the same PWM signal (from the Y-cable)shall induce a differential movement in the ailerons as required(180deg phase difference in the signal is not required).

This Y-cable cannot be used when I need to use the Flaperon configuration as I would then require a 180deg phase shifted signal on the servos (for flaps).

Please tell me how to mix two separate channels on the flytpod output such that I can get a flaperon configuration running.


#4

This type of setting is usually done by mixing the two channels.

To configure this using FlytPOD (or any autopilot), you need to choose a right mixer(frame).
This feature is available in Bormatec Maja Frame type.

Go to select FlytConsole/QGC
Select frame type -> plane -> Bormatec Maja

to set this frame

SYS_AUTO_START will be set to 2105

And output pin configuration will be 123456 <> AAERTW

A: Ailerons
E: Elevator
R: Rudder
T: Throttle
W: Wheel

Reference: http://mavlink.org/meta/airframes#BormatecMaja


#5

Thanks for the information. I have listed few more queries below,

a) While performing the RC calibration, the flap movement is not getting detected (Error pops up - Movement not detected). I have selected channel 6 dial for flap. During calibration of flaps, I moved the dial back and forth for few times and positioned the dial to full flap extended. After few minutes, the fail message pops up.
FYI,
In RC mode, CH 5 switch - RC to Altctl and selected None for RC- AP mode.


#6

Did you try using QGC? Are you still facing the issue?

Our team is looking into this. We will get back to you, at earliest.