Fixed flytPOD IP address


#1

Is there a simple straight forward way to fix the Flytpod IP address? the Flytpod/flytconsole doesn’t always respond and the dynamic ip huntung gets old quick when in the field. I’d like to be able to fix the IP so I can also enable mac table filter controls on my router when in the field!

tnx

ptegler


#2

Depends on which mode the flytpod is in. In ap mode its straightforward. On your browser access the openwrt page at 192.168.1.1
click on administration, username: root password: 123
Using LUCI interface assign a static IP to flytpod using mac address.

In client mode, your router will assign an IP address to flytpod. So the best option is to assign a static IP from your router’s page. If you don’t have access to your router then you can log into flytpod desktop. Cilck on network icon on right top corner, edit connections, edit the wired connection 1, change the IPV4 settings to manual lease. Dont forget to properly set the dns settings as well.

Refer to advanced user documentation in wifi setup at docs.flytbase.com
Let me know if you need any more details.


#3

ok…now I’ve done it. I tried setting the Flytpod ipv4 address to a fixed address and turned of DNS, even though I set a DNS server id (my main network router)

uh oh… locked it all up just like before…no access… sooo…I tried the openwrt entry stuff followed the instructions from the Feb 7 black screen message … did thesudo minicom -D /dev/ttySAC2 -b 57600 and firstboot && reboot. After a reboot… I get a lit screen, the CTRL+ALT +F1/F7 do nothing. BUT… a right mouse click pops up a menu that has all the menu items you’d see at the top left corner drop down…but no tool bars top, bottom, anywhere…and of course the wifi is not back. The MOST interesting aspect of all this… it looks like i’m running a totally different desktop…it looks like a different Ubuntu flavor or something. even the app names are a bit different!

did I really mess up??? going back to that previous message I realizee I did not mess with the lightdm.conf parts… I only ran the minicom and reboot stuff rather than having run

sudo sed -i ‘s/autologin-user=flytpod//g’ /etc/lightdm/lightdm.conf
sudo rm -rf /home/flytpod/.config
before having run the
sudo minicom -D /dev/ttySAC2 -b 57600
firstboot && reboot

So now I’m really lost. WHAT in the world did i do?

ptegler


#4

ok… got the pod back… OPENBOX was the environment running! ???
by playing with the menus and file system, changing the menubar I noticed a pull down that let you select Openbox, Lubuntu, (and one other one I can’t remember right now) Anyway I’m back to a desktop at least.
BUT… hdmi and keyboard on the pod… I don’t have the applications meny any longer…and the AP and Cleint wifi stuff just does NOT work…no blinking blue light even after re-running the commands to reset to default, the router state in openwrt
… I’m finding more and more stuff just not documented…or you might consider just shutting off or disabling anything NOT needed so buttheads like me can’t mess it up. :slight_smile:

So how do i ge the router running aghain…and get back the menu of the apps installed in Lubuntu by default?

petgler


#5

We are cooking something special for you @pteg :wink:
Just testing out the flow to put your system back to as it was when shipped. Will get back to you soon.


#6

What is the exact problem you are facing with router?

After reseting router using firstboot && reboot the router goes into AP mode (you have to press y as the above command prompts you to). Can you access the FlytPOD_wifi access point (from your phone) when you reset it. If not, then please share a screenshot of the terminal where you ran this command and its output.

If you are able to connect to wifi access point (FlytPOD_wifi) but not able to reach flytconsole then dont worry. The mess in you linux system could be responsible for this. Lets work it out separately.

Please explain what exactly doesn’t work in ap client stuff, so that I can help you out.

Btw, if you are not able to terminal using HDMI desktop then you can press ctrl+alt+t to get a terminal. If that doesn’t work press ctrl-alt-f1 and you will have the terminal. The minicom command can be run in any of these command prompts.


#7

Hi Dhirajd,
you had previously given me a sequence to get the router reset to defaults…running the openwrt in a terminal window.
I have repeated that sequence at least twice now, used the button to shut down and after a reboot have still not been able to get the wifi to respond. During boot up the blue wifi led will be on solid, then it will blink a couple times just as the very first flytpod logo screen appears (hdmi on the pod itself) then the led turns off and never blinks or turns on again until a reboot sequence starts. I haven’t tried getting to it with my phone, but the flyt console is accessible on the pod, But no matter what I set up on the AP or client, I get no response from the wifi. I’ll try booting this a.m. and pull out my RF Explorer to see if the router ever kicks out any signal even momentarily.


#8

ok…go into the openwrt via my iphone… now have the openwrt page open in Firefox on the pod.
Acrylic WIFI (on my PC) is now displaying FlytPOD_wifi with a decent power level (only 2 dbm lower than my main network router)

openwrt is showing an IP for my iphone and for the flytpod, but using localhost, the display IP, flytpod/flytconsole… even on the pod none will currently connect/display to the console

what is the ‘LUCI’ page in openwrt?? I see a TAB for the NETWORK, but don’t want to chance scrambling things further by setting a fixed IP. I can also see that right now it appears to be configured as a hotspot

ok…belay that…I see LUCI in the browser window address bar while displaying the openwrt pagesstill no connection to the flytconsole, not from the iphone, pc, or even right on the pod


#9

Hi @pteg,

Can you tell me if you are powering up the device with VI port or the power jack? Wifi-router not working correctly could be because of some power issue. It would be better if you plug-in the power jack first and then insert the VI cable. I hope this helps.


#10

strickly running off the wall wart power supply right now. I have the two GPS units (pod/Pro), RC receiver and etc all mounted on a board on the bench.

Was able to get into the openwrt from my iphone… then on the pod itself. But I didn’t want to change anything just yet. My ‘Arylic WIFI’ app shows a good strong wifi signal from FlyrtPOD_WIFI, but can not get the console to come up regardless of address, even using what openwrt said the address(s) was. (it showed my iphone and one other, but none respond in a browser on the pod , pc or iphone


RSSI ADC pinouts
#11

Some more info for you: The wifi router inside FlytPOD is connected with Odroid over an ethernet connection. This router runs OpenWRT firmware. In AP mode this router hosts the wifi access point and is assigned IP 192.168.1.1. The openwrt page that you have seen is hosted by this router. So if you are getting wifi access point then it means rotuer is working. If you can ping to FlytPOD(odroid) then it means that odroid is also up and connected to the router. But if FlytConsole is not working then either you are using wrong address or FlytOS is not running. A good way to test it from you laptop is to open a terminal and ping FlytPOD’s ip address. If you are connected to wifi network and are able to ping flytpod then odroid and linux system on it is up. Then open flytconsole with this url http://flytpod .
If this doesn’t work then you have problem with FlytOS startup.
You can open a terminal on flytpod or ssh to it and run following command.
rosnode list
Please attach the screenshot of the output. I will be able to help you out then.


#12

there is one ‘fail’ on boot up, but I’ve yet been able to tell what kernel file is stated right before that line (goes by too quick
10 or more times seeing it just can’t catch it before it scrolls orr screen.)
Is there a boot up log file I could look at?

ok… iphone connecting to flytpod_wifi works…first page up is the openwrt graphic interface. I wish I could capture all that info but alas no printer connection nor pc connection…tried emailing the page from the iphone but only get partial pages (what is displayed in Safari browser at any one given time)

did some reading today on openwrt… relayd says it needs two different domains and the pod is 192.168.1.1…
THAT is also my home router address… confused there what to doa considering this once worked in AP and client mode alike.

On the pod (direct keyboard and hmdi) after boot up in firefox… addressing to 192.168.1.1 brings up the openwrt interface…defaults to the firmware page… going to administration tab (top right corner) I get the login screen. log in works ok as documented.

OVERVIEW tab…mid page …DHCP says Flytpod ipv4 192.168.1.200 but entering that in the browser simply returnsd can’t connect

ok… just did a ‘page save as’ on every config page/tab of the LUCI, tar’ed them, copied them to a thumb drive… now I need an email address I could send them to for you to analyze…hopefully spot what’s wrong here.

ptegler


#13

Ignore the fail message on bootup. Relayd and client mode are already taken care of. When you switch to client mode using flytconsole FlytOS takes care of proper ip configuration for router. So you don’t really need to worry about it unless you are manually changing some settings into the router. You can just use this openwrt page to find out the IP address of FlytPOD in case no other way works.
What I need is a screenshot of the output of following command. Connect FlytPOD to display and keyboard. Open a terminal on FlytPOD. Run following command, take a snapshot of command using iphone and post it here.

rosnode list

That’s all I need to know. If you are able to reach FlytPOD and FlytConsole is not working then it means FlytOS startup is failing because of some misconfiguration. Send me this snapshot so that I can confirm your problem. Also email me files present in following folder, /flyt/logs/startup
My email is dhiraj@flytbase.com


#14

Dhirajd,
your email address would not accept emails from my main client. The address here forwarded emails over, so I just changed my email address here on the forums.

As in the email, the rosnode list command only returned ERROR: Unable to communicate with master!
I sent an email with the a tar file attached with the contents of the logs directory. I had tar’ed the pages from the openwrt but gmail bulked and would not accept it. The pages were saved as htrml files with sub-dirs with the content. your email address would not accept emails from my main client address ( verizon.net) so only the logs file made it through (vi gmail.com).


#15

I got your log files. My team is reviewing them and will soon respond with the actual problem if there is any. Thanks.


#16

My normal times to be able to work on this are between 4pm eastern and 10m eastern USA (GMT-5).
That’s between 3am and 9 am Mumbai time? (you’re 11 hrs ahead of me
The bigger issue I do not have any video chat software or configuration set up here, nor do I use social media in general.

If this platform is that sensitive to a power reboot or glitch in configuration, and considering the normal capacity for any quad platform to experience an unexpected power reset at any time for a variety of reasons, I do not believe there is any way we’re going to trust a $3,000.00+ craft to this operational system.

On 3/1/2017 5:27 AM, Dhiraj Dhule wrote:

Hello Paul,

We checked you startup log files and it seems the autopilot went into unknown state because of power reboot during automatic update installation. You need to follow some instructions to get it working again. Can you please connect over a video call (platform of your choice whatsapp, hangout, skype), as it will be better and quicker to solve all your problems at once. Please let me know the platform and suitable time.

Thanks and regards,
Dhiraj