Docs on another place is not clear


#1

Is the 921 on the picture representing the meaning of 921600?, 1 representative mavlink1 ?
and Is the camera on the raspberry coming from the USB camera? What should I change if I want to use a raspberry camera?
that’s all , thank you


#2

Hi,

Yes you are right. They are the actual values being set internally. I would update the doc to reflect that.

When you attach the camera, do you get a device registered at /dev/videoX (X being a number from 0)?
if yes, configure it by following this link.


#4

ok thank you . I will try again


#5

For raspi camera,

Try this if you don’t get to see any video device at /dev/videoX

sudo modprobe bcm2835-v4l2


#6

if the above command: ‘sudo modprobe bcm2835-v4l2’ fails,
then try installing uv4l (https://www.linux-projects.org/uv4l/installation/)


#7

I tried to do it, but failed.
The page is not on the image.
I have viedo0. But the following error occurs when roslaunch vision_apps cam_api.launch is executed.
what should I do ?


#8

Hi,

When you start FlytOS, it already binds itself with the camera. It seems it already has, try checking for video stream in your browser.


#9

Also,

Restart FlytOS. and post your log here.


#10

Still does not work


#11

Hi,

Follow this. And send this startup log.


#12

NODES
/flytpod/
core_api_navigation (core_api/navigation_api)
core_api_param (core_api/param_api)
core_api_setup (core_api/setup_api)
flyt_ms_node (flyt_ms/flyt_ms_node)
flytcam (usb_cam/usb_cam_node)
image_capture (vision_apps/image_capture)
mavros (mavros/mavros_node)
mode_manager (mode_manager/mode_manager)
navigation_server (navigation_util/navigation_server)
rosapi (rosapi/rosapi_node)
rostful (rostful/devserver)
web_video_server (web_video_server/web_video_server)

auto-starting new master
process[master]: started with pid [4252]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 580ed00e-4514-11e7-88c5-b827ebda247e
process[rosout-1]: started with pid [4265]
started core service [/rosout]
process[flytpod/core_api_param-2]: started with pid [4283]
process[flytpod/core_api_setup-3]: started with pid [4284]
process[flytpod/core_api_navigation-4]: started with pid [4291]
process[flytpod/navigation_server-5]: started with pid [4301]
process[flytpod/mode_manager-6]: started with pid [4311]
process[flytpod/flytcam-7]: started with pid [4319]
process[flytpod/image_capture-8]: started with pid [4324]
process[flytpod/web_video_server-9]: started with pid [4336]
process[flytpod/rostful-10]: started with pid [4345]
process[flytpod/rosapi-11]: started with pid [4352]

  • python -tt -m rostful run -h 0.0.0.0 -p 80 -s tornado ‘–ros-arg=~connections_ list:=/rocon/connection_cache/list’ ‘–ros-arg=~connections_diff:=/rocon/connect ion_cache/diff’ --ros-arg=__name:=rostful --ros-arg=__log:=/home/flytpod/.ros/lo g/580ed00e-4514-11e7-88c5-b827ebda247e/flytpod-rostful-10.log
    process[flytpod/mavros-12]: started with pid [4366]
    process[flytpod/flyt_ms_node-13]: started with pid [4377]
    [ INFO] [1496133947.664418366]: Waiting For connections on 0.0.0.0:8080
    [ERROR] [1496133948.833424427]: [LIC] Unknown Device Type
    [ INFO] [1496133949.150820108]: FCU URL: /dev/ttyAMA0:921600
    [ INFO] [1496133949.168210398]: serial0: device: /dev/ttyAMA0 @ 921600 bps
    [ INFO] [1496133949.179977954]: GCS URL: tcp-l://:5760
    [ INFO] [1496133949.187068832]: tcp1: Bind address: 0.0.0.0:5760
    [flytpod/core_api_navigation-4] process has finished cleanly
    log file: /home/flytpod/.ros/log/580ed00e-4514-11e7-88c5-b827ebda247e/flytpod-co re_api_navigation-4*.log
    [ INFO] [1496133950.887676443]: Plugin altitude loaded
    [ INFO] [1496133950.946337972]: Plugin altitude initialized
    [ INFO] [1496133950.947687209]: Plugin autopilot_app_control loaded
    [ INFO] [1496133950.989346839]: Plugin autopilot_app_control initialized
    [ INFO] [1496133950.991249938]: Plugin command loaded
    [ INFO] [1496133951.186863889]: using default calibration URL
    [ INFO] [1496133951.187617805]: camera calibration URL: file:///home/flytpod/.ro s/camera_info/head_camera.yaml
    [ INFO] [1496133951.188315054]: Unable to open camera calibration file [/home/fl ytpod/.ros/camera_info/head_camera.yaml]
    [ WARN] [1496133951.188633287]: Camera calibration file /home/flytpod/.ros/camer a_info/head_camera.yaml not found.
    [ INFO] [1496133951.188968551]: Starting ‘head_camera’ (/dev/video0) at 320x240 via mmap (yuyv) at 30 FPS
    [ERROR] [1496133951.192007131]: Cannot open ‘/dev/video0’: 1, Operation not perm itted
    [ INFO] [1496133951.213270577]: Plugin command initialized
    WARNING:root:ZMQ : Protobuf message implementation not found. Using pickle based protocol
    [flytpod/flytcam-7] process has died [pid 4319, exit code 1, cmd /flyt/flytos/fl ytcore/lib/usb_cam/usb_cam_node __name:=flytcam __log:=/home/flytpod/.ros/log/58 0ed00e-4514-11e7-88c5-b827ebda247e/flytpod-flytcam-7.log].
    log file: /home/flytpod/.ros/log/580ed00e-4514-11e7-88c5-b827ebda247e/flytpod-fl ytcam-7*.log
    [ INFO] [1496133951.873213706]: Plugin distance_sensor loaded
    [ INFO] [1496133952.302288813]: Plugin distance_sensor initialized
    [ INFO] [1496133952.304920826]: Plugin ftp loaded
    [ INFO] [1496133952.441015983]: Plugin ftp initialized

Is it this one???


#13

Are you sure, the device is not being used by some other process? I hope you tried restarting your raspi.


#14

Can you please add yourself to video group:

sudo usermod -aG video $USER


#15

ok I’ll try it. thank you


#16

I have another question .
Can you use OpenTLD on raspberry 3?
I compile FlytOpenTLD using the ‘catkin_make’ command.but An error occurred


#17

Running sudo catkin_make would never work. Please run without sudo:

catkin_make

should work just fine.


#18

I tried, there were other problems


#19

well that my friend happened because you tried to build(catkin_make) with sudo in the first place.

May i know why is the folder lying at root? and not at your /home/flytpod directory? Please use this directory, otherwise you will face issues(permission denied).


#20

I rewrote the mirror, but the problem remains the same


#21

Hi,

I am sorry, but why are you using sudo everywhere :smiley:
This time while git cloning you went with sudo git clone…

Two options:

  1. stop using sudo
  2. run this command

sudo -s

then run catkin_make