DJI stoping on every waypoint


#1

Hi, I’m having some trouble using DJI waypoint missions. I can successfully use this command to set waypoint and execute missions. But the drone is behaving aggressive, and comes to a complete stop on every waypoint until going to the next one. I’m sending the waypoint_set command over cloud REST API, and making sure to set param1(Time to stay at the location in sec) as zero.
We are using a Matrice 100 and FlytOS running on a Raspberry Pi B.
Is there a way to configure how DJI drone will behave upon reaching a waypoint? Make it only past by the waypoint without stoping. Also, is there a way to configure the speed the drone will fly from one waypoint to the next one?


#2

Hi @Marcello,

The behaviour you are observing is standard Waypoint Mission behaviour of a DJI drone, when commanded using its Onboard SDK.

There is indeed a setting which DJI had exposed, but last we tested a few months back. It was not working correctly. We will try this again soon.

No. There isn’t one at this moment, but it is in our backlog. This should be made available for end users in the next FlytOS release.


#3

When do you guys intend to develop these features? Being able to set up general speed of flight and behavior upon reaching waypoint is extremely important for our solution.