Dark Image on RPI cam and Cloud access question on 4G link


Hello, I was able to get my pixhawk and Pi3 with Pi cam installed and working on a lan network (Wifi). My goal is to experiment with 4G cloud control and video. Am I correct that I need to wait to have access to FlytCloud in order to try this? I did submit my request and would love to try it out.

Also, I have 2 more questions:

  1. My video feed is really dark and dim and the normal terminal raspberry pi commands are not working for me, any suggestions?

  2. If I am able to use the cloud system, Which if any of my 4G connections would require a static-public IP address, Drone, Groundstation or both?


Yes, our team needs to sign you up for the cloud beta trial access. They will soon send you an email with more information.

Are you using FlytPilot app to view the stream? There is an option to change brightness of the camera in settings tab of the app.

No, none of your devices need static and/or public IP. FlytCloud does that for you. You just need to connect drone to internet and then open FlytLive webapp from your myflytbase account. You will receive instructions to do the same when you are signed up for beta access.


Thank you for your quick reply.
I have tried the Flytpilot android app or “FlytConsole” by navigating to my local IP address I assigned as There are no options for brightness that I can see. Am I missing something?


Hello, just to follow up again. Can you please briefly explain how to access the flytlive web app? Is this something that is accessible through now or do I have to wait for the cloud access approval to go through?

My 4G dongle just arrived today and I have it connected to the RPi3. I I’m really looking forward to trying out the flytcloud!


Yes. Access to FlytLive is not available until you have cloud access approval.


You just need to update your Flytpilot App.
then check for Brightness option in camera settings.