Could not detect autopilot error



I have rpi 3b+ connected to a pixhawk 2.1. However, when I check the startup log the serial port is detected at a baudrate of 57600 (also tried 921600 and same issue), but the the APM autpilot is not detected. How can I resolve this issue?



Also, I am using telem1… don’t know if that could be the issue. Telem 2 in my setup is connected to a laser.


Seems like the hardware wire connection is not stable.
Also, try to increase Telem1 baudrate to 921600.



I have changed the baudrate to 921600.
Arducopter seems to be detected, which can be seen by the output of the runlog. However, the connection seems to disconnect.



Specifically, when launching flytOS my error is:

[FATAL] [1563473194.879724368]: heartbeat timeout called… check serial connection to autopilot… restarting mavros
[flytos/mavros-2] process has died [pid 3222, exit code -9, cmd /flyt/flytos/flytcore/lib/mavros/mavros_node __name:=mavros __log:=/home/asw/.ros/log/acdedce0-a986-11e9-b08d-b827eb264e91/flytos-mavros-2.log].
log file: /home/asw/.ros/log/acdedce0-a986-11e9-b08d-b827eb264e91/flytos-mavros-2*.log


This shows that hardware connection is not stable. Can you please share the startup log.
Moreover, can you use the same connection to connect to a laptop running Mission Planner or any other GCS.


flyt_runlogs.log (519.1 KB)
flyt_startup.log (80.4 KB)


I can connect to mission planner (using a UDP connection, via wifi), the hud was responsive. I tried using the 4g connection but it was taking a long time.

When I launch flytconsole it shows as disconnected even though I have a strong 4G connection.