Can't access video streams: 500 Internal Server Error


#1

I am running FlytSim on ubuntu desktop with ros/gazebo.

Things I tried:

  • FlytSim is installed and runs successfully.
  • Autopilot Stack: PX4 SITL
  • running ls /dev/video* in the terminal: /dev/video0
  • running cheese in the terminal: successfully opens a stream from the webcam.

The Problem
Yet when I launch FlytSim it doesn’t recognise the video in FlytConsole, and trying to access http://<ip>/list_streams results in 500 Internal Server Error.

Any help appreciated.

flyt_runlogs.log (75.4 KB)


#2

Well, I am confused. Are you trying to access your USB Camera/Web camera via FlytSim?
FlytSim only recognises the simulated camera from Gazebo environment.

Do you want to simulate the drone OR test video streaming of real camera?
If testing video streaming is what you seek, run this command in your terminal:

sudo sh -c ‘wget -O - https://downloads.flytbase.com/flytos/install/flytOS.sh | bash’

This would install FlytOS on your machine, which can connect to your camera.


#3

and how exactly do i get the simulated camera in gazebo to work?


#4

Search for camera access in this page -> http://docs.flytbase.com/docs/FlytSim/docker/troubleshooting.html#why-dont-i-see-gazebo-gui-when-i-launch-flytsim


#5

I did that already.

and gazebo launches on my linux machine, but how do I add a camera to it?


#6

When you enable the Camera slider, it automatically attaches a camera.

Can you please send me your runlog?


#7

I did in the opening post.


#8

Yes. My bad. I had looked into the log. There seems to be a bug. I am currently working on it. Will push the update ASAP.


#9

I have updated the FlytSim Image.
Please run the start.sh script to let FlytSim update itself.


#10

updated, but still not working.

My screenshot looks like this, even when I plug in a usb camera.

attached are the run logs.
flyt_runlogs.log (63.5 KB)


#11

It seems there is some confusion regarding camera/video in FlytSim. As I have told before, FlytSim only recognises the simulated camera from Gazebo environment. It cannot detect your USB camera.

Please attach your USB camera to RPi which has FlytOS installed and running.


#12

Hi
I installed new flytSim on AWS
started it but have no access to video once more



#13

My logsflyt_startup.log (13.3 KB)
flyt_runlogs.log (237.7 KB)


#14

Hi @shuki,

Please make sure, that you have enabled ‘camera’ in FlytConsole settings section.
If done, ssh into your VM via -XC command so that the session has xserver running. This should solve your issue.

ssh -XC servername@serverIP


#17



flyt_startup (1).log (2.8 KB)
flyt_runlogs (1).log (171.2 KB)


#18

it seems to me need run docker from user regular, but cannot b permission


#19

Hi
do you have ideas?