Can't access video streams: 500 Internal Server Error


I am running FlytSim on ubuntu desktop with ros/gazebo.

Things I tried:

  • FlytSim is installed and runs successfully.
  • Autopilot Stack: PX4 SITL
  • running ls /dev/video* in the terminal: /dev/video0
  • running cheese in the terminal: successfully opens a stream from the webcam.

The Problem
Yet when I launch FlytSim it doesn’t recognise the video in FlytConsole, and trying to access http://<ip>/list_streams results in 500 Internal Server Error.

Any help appreciated.

flyt_runlogs.log (75.4 KB)


Well, I am confused. Are you trying to access your USB Camera/Web camera via FlytSim?
FlytSim only recognises the simulated camera from Gazebo environment.

Do you want to simulate the drone OR test video streaming of real camera?
If testing video streaming is what you seek, run this command in your terminal:

sudo sh -c ‘wget -O - | bash’

This would install FlytOS on your machine, which can connect to your camera.


and how exactly do i get the simulated camera in gazebo to work?


Search for camera access in this page ->


I did that already.

and gazebo launches on my linux machine, but how do I add a camera to it?


When you enable the Camera slider, it automatically attaches a camera.

Can you please send me your runlog?


I did in the opening post.


Yes. My bad. I had looked into the log. There seems to be a bug. I am currently working on it. Will push the update ASAP.


I have updated the FlytSim Image.
Please run the script to let FlytSim update itself.


updated, but still not working.

My screenshot looks like this, even when I plug in a usb camera.

attached are the run logs.
flyt_runlogs.log (63.5 KB)


It seems there is some confusion regarding camera/video in FlytSim. As I have told before, FlytSim only recognises the simulated camera from Gazebo environment. It cannot detect your USB camera.

Please attach your USB camera to RPi which has FlytOS installed and running.


I installed new flytSim on AWS
started it but have no access to video once more


My logsflyt_startup.log (13.3 KB)
flyt_runlogs.log (237.7 KB)


Hi @shuki,

Please make sure, that you have enabled ‘camera’ in FlytConsole settings section.
If done, ssh into your VM via -XC command so that the session has xserver running. This should solve your issue.

ssh -XC servername@serverIP


flyt_startup (1).log (2.8 KB)
flyt_runlogs (1).log (171.2 KB)


it seems to me need run docker from user regular, but cannot b permission


do you have ideas?


@srv-admin Still don’t have a solution for accessing the video?


So I freshly installed FlytSim on my machine and configured it for PX4 mode and enabled camera.

Please make sure FlytSim version at top corner is v1.5-8.

Moreover, the issue might be due to AWS installation. Please verify that the streaming is working fine in your local machine. On AWS VM, you would have to configure X-server to get video streaming. Your logs suggest that it is not enabled, as the Gazebo GUI crashes as well.

If you give me access to your VM (in a private message), I may try to take a look into this.


Thanks I will check it