Can not launch Flysim properly


#1

Hi all,

I have just installed the Flysim and are going to test it following this tutorial([docs.flytbase.com/docs/FlytSim/F ... sim-basics](http://docs.flytbase.com/docs/FlytSim/FlytSimLaunch.html#flytsim-basics)),however, when I typed the following:

rosservice call /flytsim/navigation/take_off “takeoff_alt: 2.0”

I just get success: False
And I can not let the quadrotor take off. Does anyone knows how to solve this?
Thanks!

Best


#2

Hi,

There are two pre-installed CPP/Python apps as well. http://docs.flytbase.com/docs/FlytApps/OnboardApps.html
Try them out and post your results.


#3

Hi,
I have tried this instruction but unfortunately it seems failed. Maybe I should describe what I have met in detail.
After installation, I tried to start the Flysim following the command:
$ $(rospack find core_api)/scripts/start_flytOS.sh --sitl
Gazebo was launched and I can see the quadrotor and the scene, however, there is prompting in the terminal that :

[flytsim/mavros-19] process has died [pid 25299,exit code 127, cmd /flyt/flytos/flytcire/lib/mavros/mavros_node __name:=mavros __log:=home/chao/.ros/log/d7…b8763fd2f00e/flytsim-mavros-19.log ]
This prompting was appearing at a certain frequency.

If I ignore the warning above and continue with the following command:
$ rosservice call /flytsim/navigation/take_off "takeoff_alt: 2.0"
I just received : Success: False
Similarly things happened when I tried the following:
$ rosservice call /flytsim/navigation/arm

When I try the demo app with the instruction: ( docs.flytbase.com/docs/FlytApps/OnboardApps.html ) and typed the following:
$ /flyt/flytapps/onboard/install/demoapp1
There is nothing happened and the command seems to be ended after a few seconds.

I just don’t know the key to solve this problem, thanks for your help !

Best

[quote=“srv”]Hi,

There are two pre-installed CPP/Python apps as well. http://docs.flytbase.com/docs/FlytApps/OnboardApps.html
Try them out and post your results.[/quote]


#4

Hi,

[flytsim/mavros-19] process has died [pid 25299,exit code 127, cmd /flyt/flytos/flytcire/lib/mavros/mavros_node __name:=mavros __log:=home/chao/.ros/log/d7…b8763fd2f00e/flytsim-mavros-19.log ]

This is surely a big cause for concern.
What is your FlytSim version, run this command: dpkg -s flytsim

Moreover, could you explain your installation procedure? Do you have a linux installed or using virtualbox/virtualmachine?
Also, have you tried re-installing FlytSim?


#5

hi. im noob and I have the same problem
the installation was in order like say page http://docs.flytbase.com/docs/FlytOS/Developers/FlytSim/FlytSimInstallationGuide.html

My FlytSim version is:
arturoms@arturoms-VirtualBox:~$ dpkg -s flytsim-pe
Package: flytsim-pe
Status: install ok installed
Priority: standard
Section: admin
Installed-Size: 151273
Maintainer: Sharvashish Das srv@navstik.org
Architecture: amd64
Version: 1.1-1g
Depends: libavcodec-ffmpeg56 (>= 7:2.4) | libavcodec-ffmpeg-extra56 (>= 7:2.4), libavformat-ffmpeg56 (>= 7:2.4), libavutil-ffmpeg54 (>= 7:2.4), libboost-filesystem1.58.0, libboost-regex1.58.0, libboost-system1.58.0, libboost-thread1.58.0, libboost-timer1.58.0, libc6 (>= 2.14), libconsole-bridge0.2v5, libgazebo7, libgcc1 (>= 1:3.0), libglib2.0-0 (>= 2.39.4), libignition-math2, libprotobuf9v5, libsdformat4, libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 5.2), libswscale-ffmpeg3 (>= 7:2.4), libtinyxml2.6.2v5, ros-kinetic-opencv3
Description: FlytCore package
<insert long description, indented with spaces>
Homepage: flytbase.com

and i have been using a VirtualBox.

arturoms@arturoms-VirtualBox:~$ rosservice call /flytsim/navigation/take_off "takeoff_alt: 2.0"
success: False

Could u tell me please, how to fix it?
Thank u


#6

Hi Can you send the flytos startup log, as mentioned over here