Application doesn't run in FlytSim


#1

Hi everyone,

I’m trying to run demoapp1 in FlytSim. I launched FlytSim successfully and then run the demoapp1 but nothing happened in FlytSim and the demoapp1 was run in Terminal without errors. Could someone tell me where the problem is?

Thanks


#2

Hi,

When you run the app, were any errors thrown in the terminal where FlytSIM was launched.
Also, did you try running the app again. Moreover, what was the command that you executed to run the app.


#3

Thanks for your reply.
When I launch FlytSim, the following error is besides “[Warning] : clock skew detected” are displayed, otherwise, everything looks fine
[FATAL] [1493734202.852455357]: [LIC] License file NOT found, exiting
I tried running the application many times
To run the application, I run the following command
/flyt/flytapps/onboard/install/demoapp1
I also compiled my own version and tried running it using
./demoapp1


#4

Hi,

Can you please follow this flytsim activation guide, and get your FlytSIM activated. Unless you activate, demoapp won’t work.


#5

Thanks Srv, now it’s running.
I tried activating my device before but I couldn’t. The page was not opening. I knew from other question that I have to run FlytOS in order to open FlytConsole. I’d suggest adding this step in the activation guide.


#6

Hi,

Well my friend, if you run FlytSIM, FlytConsole should still open up. So there is no need of running FlytOS. Moreover please don’t get confused with FlytOS vs FlytSIM. FlytSIM is just another flavour of FlytOS, having the additional feature of an inbuilt 3d gazebo simulator. So basically, FlytSIM = FlytOS + Gazebo


#7

Yes, I knew recently that FlytSim and FlytOS are much the same (check gitter). But in the activation guide it’s not mentioned that you have to run FlytSim (or FlytOS) before opening FlytConsole. This is why I’m suggesting to add this step in the guide.


#8

Oh I understand. Thanks for bug reporting. Correcting it now. Thanks again.