A question for testing nav.arm()


#1

I connected the odroid-xu4( booted with flytos ) with pixhawk/px4 ( tested by using gpa0.0, gpa0.1 and ground to pin 2,3,6 of telem2 on pixhawk, also tested using usb-usb, understood it is not recommended ).

I was trying to test it by using demoapp1.py and demoappy2.py, I added nav.arm() before nav.take_off(3.0)
also tried nav.disarm()

so far, there seems no communication between the odroid-xu4 and pixhawk, these two don’t seem to talk. ( call nav.aarm(), nav.disarm(), nav.taek_off(3.0)… there is no response on the pixhawk side )

I can arm/disarm from qgroundcontrol, so I know arm/disarm work on pixhawk. Just trying to figure out what is going on between odroid-xu4( flyos ) and pixhawk(px4).

I am trying to go through each step:

  1. do I connect them correctly or not, ( tested with gpa to telem2, and usb-usb )
  2. I installed flytos on odroid-xu4, ssh in, everything looks correct.

Now I am scratching my head, where am I having what issues?

shed some light please, and thank you in advance!


#2

from flytos/odroid-xu4, I can
screen /dev/ttyUSB0 57600 8N1

connect to seriel2 on pixhawk and got nsh> prompt. So usb/flytos to seriel2 on pixhawk communicates.

However, gpa to telem2, or usb-usb don’t seem to communicate … ( yet …

without mavproxy, is there any other way I can verify the communication between flytos and px4?

Thank you,


#3

First of all I would like you to update your FlytOS whenever you can.

We have a pre-packaged web-app, FlytConsole, that comes with FlytOS. Launch the web app from your own device by following docs.flytbase.com/docs/FlytPOD/G … lytconsole.

To know more about FlytConsole widgets, follow docs.flytbase.com/docs/FlytConso … nsole.html


#4

In the FlytConsole dashboard, check the status Connected/Disconnected with the ODROID running FlytOS.
In the GCS widget, check whether messages for Attitude or Position are being published or not.

Moreover, follow the FlytAPI documentation, docs.flytbase.com/docs/FlytAPI/ListOfAPIs.html carefully before proceeding forward. Even though API for Arm is available, the Takeoff API would inherently call Arm API. So for all general applications you dont need to call Arm API unless needed.


#5

Also, it seems that you have installed our debian package but have not used our Linux Image. If this be the case, you have to launch FlytOS using the command given in: docs.flytbase.com/docs/FlytOS/Fl … nch-flytos with every reboot or add the command to your /etc/rc.local file to launch it automatically on every reboot.


#6

I opened up the flytconsole, 192.168.1.7:9090/flytconsole/index.html ( mine )
from the dashboard, it shows “Connected” with a heart, ( on the top ) and Active for “Connection Status”,

however, it does show “Disarmed” and also “No GPS”, while I switched to qgroundcontrol ( on my another laptop ) just for verifying, I can arm/disarm the motors and GPS looks correct.

So is there a place I can arm the motors? I also tested my usb cable and the connections between gpa and telem2, the cables are good cables. I am just trying to figure out why these two are not communicating …

any action from flytos side/odroid-xu4, there is no response from the pixhawk side …


#7

As I said earlier as well, you have to update your FlytOS before moving ahead. Do that before testing further.

Now, after updating the FlytOS, if the connection status still points to “Connected”, this means the link between ODROID and PX4 is alright.

As earlier suggested go to GCS widget and check whether Attitude/Position fields are getting populated or not. You should also try to Calibrate your sensors using the Calibration widget.


#8

yeah, I went ahead run dpkg -s flytcore and make sure all pkgs are the latest.
flytconsole shows connected and active on “connection status”.

when I unplugged the power core of pixhawk, pixhawk was powered, all lights were still blinking, until I unplugged the power supply to the odroid, everything went dark. This indicates the connection between odroid and pixhawk is active, matching flytconsole shows.

I just need to figure out how to let pixhawk act following the instructions like arm/disarm/takeoff/land from flytos side …

Do I need adjust any baudrate on the pixhawk side ?

thanks,


#9

Hi,

Could you post the dpkg -s status over here. Moreover, I couldn’t stress more but if the FlytConsole states “connected” then it means your connection between Pixhawk and ODROID is ABSOLUTELY OK.
As I have been suggesting since last couple of posts, before moving forward with vehicle arming, try vehicle calibration and post your results. Also check whether Attitude/Position fields are getting populated or not.

As a side note, it would be beneficial for both of us, if you could tell me about the application for which you are trying to set up your vehicle. You could also do away with the issues with vehicle integration and instead participate in our FlytPOD beta program flytbase.com/flytpod/#beta


#10

root@flytpod:/flyt/flytapps/onboard/install# dpkg -s status
dpkg-query: package ‘status’ is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
root@flytpod:/flyt/flytapps/onboard/install# cat /etc/os-release
NAME="Ubuntu"
VERSION="14.04.4 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.4 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
root@flytpod:/flyt/flytapps/onboard/install#cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.4 LTS"
root@flytpod:/flyt/flytapps/onboard/install#

I thought I downloaded/burned/installed flyosimage onto my microSD, then it boots up the Odroid-xu4 pretty good. However, if you spot anything not right, please let me know, I can re-go through the flytos installation process, ( download, install flytosimage onto the microSD )

thanks much for your help!


#11

Hi,

My bad, by dpkg -s status, i meant ----> run this command dpkg -s flytcore. Check if it says version as 0.4-1. Nevertheless post its result in this thread.

Moreover, reiterating again,
As I have been suggesting since last couple of posts, before moving forward with vehicle arming, try vehicle calibration and post your results. Also check whether Attitude/Position fields are getting populated or not.

Any success with this?

As a side note, it would be beneficial for both of us, if you could tell me about the application for which you are trying to set up your vehicle. You could also do away with the issues with vehicle integration and instead participate in our FlytPOD beta program flytbase.com/flytpod/#beta

Would you link to know more about our beta program?


#12

i have same problem with you
I can arm/disarm from qgroundcontrol, so I know arm/disarm work on pixhawk. Just trying to figure out what is going on between odroid-xu4( flyos ) and pixhawk(px4) no response on the pixhawk side

thank you


#13

This thread was closed as the problem was resolved in another thread. Please go through this thread: viewtopic.php?f=9&t=35 and post your issues there.

Gist of the other thread:

  1. What is your FlytOS version?
  2. What is your configuration parameters for Telem2 port i.e. what is your baud rate?(SYS_COMPANION) (MUST be 921600)
  3. Set the parameter MAV_COMP_ID to 50.
  4. Once done, run this command and revert back, preferable in the above thread.