:9090/flytconsole Dashboard always shows connected no matter what


#1

I loaded the latest firmware on my px4 ( 04/17/16 ), the flytOS image is flytOS_lubuntu_14.04.1_20160226.img

I disconnected/separated odroid xu4 and pixhawk/px4, however,
…:9090/flytconsole Dashboard still shows Connected and Active on “Connection Status”.

anything I did wrong or anything I should/can do with this situation?

Thank you,


#2

this is even after I rebooted both lubuntu/odroid xu4, and px4/pixhawk multiple times. these two are now completely disconnected, however, flytconsole still shows Active on “Connection Status”.


#3

Hi,

Run this command in your terminal. dpkg -s flytcore. Post your result.


#4

flytpod@flytpod:~$ sudo dpkg -s flytcore
[sudo] password for flytpod:
Package: flytcore
Status: install ok installed
Priority: standard
Section: admin
Installed-Size: 80814
Maintainer: Sharvashish Das srv@navstik.org
Architecture: armhf
Version: 0.2-6
Depends: libboost-filesystem1.54.0, libboost-python1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.12), libconsole-bridge0.2, libgcc1 (>= 1:4.4.0), libopencv-core2.4, libopencv-highgui2.4, libpython2.7 (>= 2.7), libstdc++6 (>= 4.8.1), libtinyxml2.6.2, liburdfdom-world0.2
Description: FlytCore package
<insert long description, indented with spaces>
Homepage: flytbase.com
flytpod@flytpod:~$

The above is the result of dpkg -s flytcore

thanks,


#5

Hi,

So it says that your version is 0.2-6. Update it to the latest version following: http://docs.flytbase.com/docs/FlytOS/FlytOS_install.html#flytos-update.

Moreover, FlytConsole loads itself from browser cache. So if you are facing such issues, then try removing cache and reloading FlytConsole. To do this, once FlytConsole is opened, using ctrl+R would reload the page, but ctrl+shift+R would remove the cache and reload FlytConsole.


#6

Hi,

Any update would you like to share? Have your problems been resolved?


#7

Now the flytconsole shows “Disconnected” and “Offline” for the connection status, after I finished:

  1. downloaded flyOS_0.4-1_armhf.deb and run: dpkg -i flyOS_0.4-1_armhf.deb
    now:
    root@flytpod:/flyt/flytapps/onboard/install# dpkg -s flytcore
    Package: flytcore
    Status: install ok installed
    Priority: standard
    Section: admin
    Installed-Size: 76313
    Maintainer: Sharvashish Das srv@navstik.org
    Architecture: armhf
    Version: 0.4-1
    Depends: libavcodec54 (>= 6:9.1-1) | libavcodec-extra-54 (>= 6:9.18), libavformat54 (>= 6:9.1-1), libavutil52 (>= 6:9.1-1), libboost-filesystem1.54.0, libboost-python1.54.0, libboost-regex1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.12), libconsole-bridge0.2, libgcc1 (>= 1:4.4.0), libopencv-core2.4, libopencv-highgui2.4, libopencv-imgproc2.4, libopencv-video2.4, libpython2.7 (>= 2.7), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.8.1), libswscale2 (>= 6:9.1-1), libtinyxml2.6.2, liburdfdom-world0.2
    Description: FlytCore package
    <insert long description, indented with spaces>
    Homepage: flytbase.com
    root@flytpod:/flyt/flytapps/onboard/install#

  2. I updated the latest firmware of px4

connect gpa0.0/gpa0.1/ground to telemetry2, ( also tested by connecting usb to usb ), rebooting, ctl+R, crl+shft+R…
flytconsole just always shows “Disconnected” and “Offline” for the connection status.

next, I am ordering two pieces of “USB-TTL” to see USB on Odroid to telemetry2 on pixhawk, and see flytconsole can detect any connection or not.

So before updating flytpod, firmware on pixhawk, flytconsole always showed connected, after the updating, now it always show Disconnected.

Thank you,


#8

Hi,

  1. Now, when you launch FlytOS, do you see any error messages popping up?
  2. Try this command,

Do you see any data.
3. Lets see what is your configuration parameters for Telem2 port i.e. what is your baud rate?(SYS_COMPANION)
4. I am also sorry that I forgot to notify before, and this needs to go to documentation as well, the parameter MAV_COMP_ID needs to be set at 50.
5. Just to be sure, but you obviously tried to connect QGC with Pixhawk on the Telem2 port right?
6. Even though you are encouraged to try out USB-TTL method, but when we tried we were facing a lot of connection issues.


#9

Hi,

  1. Now, when you launch FlytOS, do you see any error messages popping up?

I see the below two: ( the 2nd one is in red on my screen )

process[flytpod/rostful-2]: started with pid [3666]

  • python -tt -m rostful run -p 9090 -s tornado --ros-arg=__name:=rostful --ros-arg=__log:=/root/.ros/log/5bbf982e-09c8-11e6-a463-3c33005001a4/flytpod-rostful-2.log
    process[flytpod/rosapi-3]: started with pid [3676]
    No handlers could be found for logger "rosout"
    WARNING:root:Error: could not import RoconInterface - disabling. No module named rocon_app_manager_msgs.msg
    the rosdep view is empty: call ‘sudo rosdep init’ and 'rosdep update’
    started roslaunch server flytpod:33607/

    the rosdep view is empty: call ‘sudo rosdep init’ and 'rosdep update’
    core service [/rosout] found
    process[flytpod/mavros-1]: started with pid [3725]
    process[flytpod/navigation_server-2]: started with pid [3731]
    process[flytpod/core_api_param-3]: started with pid [3735]
    process[flytpod/core_api_setup-4]: started with pid [3742]
    process[flytpod/core_api_navigation-5]: started with pid [3752]
    process[flytpod/mode_manager-6]: started with pid [3754]
    ERROR: cannot launch node of type [usb_cam/usb_cam_node]: usb_cam
    ROS path [0]=/opt/ros/indigo/share/ros
    ROS path [1]=/flyt/flytos/flytcore/share
    ROS path [2]=/flyt/flytos/flytcore/stacks
    ROS path [3]=/opt/ros/indigo/share
    ROS path [4]=/opt/ros/indigo/stacks
    process[flytpod/image_capture-8]: started with pid [3762]
    process[flytpod/web_video_server-9]: started with pid [3778]
  1. The output of the cmd "rostopic echo /flytpod/mavros/state"
    root@flytpod:~# rostopic echo /flytpod/mavros/state
    [WARN] [WallTime: 1461467406.893543] Inbound TCP/IP connection failed: connection from sender terminated before handshake header received. 0 bytes were received. Please check sender for additional details.
    header:
    seq: 0
    stamp:
    secs: 1461467210
    nsecs: 929042061
    frame_id: ''
    connected: False
    armed: False
    guided: False
    mode: ''
    mav_type: 0
    mav_autopilot: 0
    mav_sys_status: 0

^Croot@flytpod:~#

  1. Lets see what is your configuration parameters for Telem2 port i.e. what is your baud rate?(SYS_COMPANION)
    Can I know to look at this parameter? when I boot from the Odroid Lubuntu running mavproxy, I use baudrate=57600, I am able to “arm throttle”/“disarm” to verify the connection between odroid and pixhawk. So I think the baudrate is 57600 and the connection ( usb to telem2 ) should be good.

  2. "…the parameter MAV_COMP_ID needs to be set at 50…"
    Can I know how to set the MAV_COMP_ID to 50?

  3. Just to be sure, but you obviously tried to connect QGC with Pixhawk on the Telem2 port right?
    Yes. I tried. Before I updated the software, flytpod showed connected, after I updated, so far it shows disconnected ( even after I connected everything, usb to telem2 connection works, because I tested using another odroid lubuntu with mavproxy arm throttle/disarm commands )

  4. Even though you are encouraged to try out USB-TTL method, but when we tried we were facing a lot of connection issues.
    I agree 100%. That is why I am trying my best to see how to make gpa0.0/gpa0.1/ground <–>telem2 connection work.
    using odroid lubuntu usb<->telem2 is to verify the telem2 ports are good. ( make sure the physical ports, cables are all good )

Thanks so much for your help!


#10

Hi,

  1. The error messages are harmless.
  2. The output suggests that the system is not in a connected state.
  3. To set this parameter, you either need a console access of Pixhawk or you have to use QGC. In QGC, search for this parameter (SYS_COMPANION) under System tab and set it to 921600. FlytOS expects data in this baud rate of 921600, and not 57600.
  4. Again to set MAV_COMP_ID, you either need a console access of Pixhawk or you have to use QGC. In QGC, search for this parameter (MAV_COMP_ID) under Mavlink tab and set it to 50.

#11

Hi Srv,
Once I set SYS_COMPANION to 921600 and MAV_COMP_ID to 50, flytconsole now shows connected, and active with a blinking/pumping heart for connection status. Thanks for your help!
GPS lock and power voltage all show up, Very nice!

So now if I go through the calibration, then will I be able to arm/disarm the motors? something like that? ( Right now, I click “arm”, it says “Arm Message Rejected, system error…”

Thanks again!


#12

looks like things work good, except I can’t arm the motors, also when I click on “Motor testing”, it really doesn’t move the motors.

I tried to run from python, nav.arm() returns 1 instead of 0, so can’t arm the motor.

So please shed some light on how I can arm the motors…

thanks,


#13

Hi,

Its great that things have started to work out. Regarding the ESC Calibration and Motor Testing widgets, they are designed to work only with FlytPODs: flytbase.com/flytpod/#beta. As both these widgets require customised Autopilot which only comes packaged with FlytPOD. As far as I remember all other widgets should work just fine.

Just to be doubly sure, go to the GCS tab, and check whether you can see Attitude and Position data getting populated or not.

Moreover, you have to configure on of your RC switch positions in OFFBOARD mode, and flip the switch into OFFBOARD position. Once that happens, you must verify that the vehicle mode status at the dashboard suggests API|POSCTL. Once you have tested this, with Pixhawk emitting GREEN STEADY BLINK, try sending the TAKEOFF command. (it would lift off the vehicle by about 5m above ground).

Even after doing all of this if you are still receiving error messages, try posting the exact message over here.


#14

Hi,
Thanks for the explanations. So:

  1. Is it possible to arm/disarm the motors ( just for testing ) without configuring the RC?
  2. running demoapp1 and demoapp2 should be good without RC, is it correct?

I am using qgroundcontrol to arm/disarm the motors, and launch pixhawk with my RC. However, the nice part of flyt if I understand it correctly is that it provides an API which makes the programming easier.

RC lets me control pixhawk, but programming gives me the automation. ( even I can define the mission plan, waypoint… to let it fly based on the plan … )

thanks,


#15

Hi,

Yes, it is possible to ARM/DISARM without the requirement of RC. But as a safety concern, within FlytOS we have made sure that user does not fly his drone(use FlytAPIs) unless he has a RC. Until and unless both the hardware and software platforms are fully tested, it is recommended to have a RC, just as a standby equipment in case of emergency.
Hence, none of the apps would work without the RC. You can at most ARM/DISARM the vehicle without RC.

"I am using qgroundcontrol to arm/disarm the motors, and launch pixhawk with my RC. However, the nice part of flyt if I understand it correctly is that it provides an API which makes the programming easier.

RC lets me control pixhawk, but programming gives me the automation. ( even I can define the mission plan, waypoint… to let it fly based on the plan … )"

Yes, all of that is true. This is what our aim was from the beginning. But as a safety concern, we still want the user to configure his RC. Maybe in future stable releases, we could do away with such checks inside FlytOS.


#16

Hi,

I am extremely sorry for my wrong information in the last post. ARM API also has the similar check for RC (you need to configure the OFFBOARD switch and flip it to enable the mode). Just the DISARM API does not care about the switch position.